Bug 847570 - Wacom Tablet Support Regression
Wacom Tablet Support Regression
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-12 22:26 EDT by Ryan H. Lewis (rhl)
Modified: 2012-10-14 06:46 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 11:14:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/bus/input/devices (5.00 KB, text/plain)
2012-08-12 22:26 EDT, Ryan H. Lewis (rhl)
no flags Details
Conversation with Peter Hutterer in #linuxwacom in reference to this. (1.80 KB, text/plain)
2012-08-12 22:27 EDT, Ryan H. Lewis (rhl)
no flags Details
Fixes from 3.6.0-rc2 to restore wacom touch screen functionality in 3.5 (1.51 KB, patch)
2012-09-30 08:47 EDT, Jeremy Uchitel
no flags Details | Diff

  None (edit)
Description Ryan H. Lewis (rhl) 2012-08-12 22:26:32 EDT
Created attachment 603838 [details]
/proc/bus/input/devices

Description of problem:
In  Kernel 3.4.4-3 my Wacom Tablet inside my Fujitsu T901 worked. In Kernel 3.5.1 and 3.5.0 it does not

Version-Release number of selected component (if applicable):
Kernel 3.5.1

How reproducible:
Always

Steps to Reproduce:
1. Boot into new kernel
2. Notice that multitouch and pen do not register as input devices
  
Actual results:
Nothing

Expected results:
Processed input events

Additional info:
Comment 1 Ryan H. Lewis (rhl) 2012-08-12 22:27:13 EDT
Created attachment 603839 [details]
Conversation with Peter Hutterer in #linuxwacom in reference to this.
Comment 2 Ryan H. Lewis (rhl) 2012-08-22 13:34:45 EDT
recursive rc kernel testing shows that the bug appears between:  0.rc0.git6.1.fc18 and 0.rc0.git7.1.fc18.

I discussion in #fedora-kernel narrows us down to a possible 14 commits causing this problem, assuming the problem occurs in wacom.c
Comment 3 Daniel Laczi 2012-08-25 18:10:00 EDT
Same problem here with my ThinkPad X220 Tablet.

Everything is running fine with kernel 3.4.6-2 and older ones. The problem occurs with 3.5.* kernels. I have exactly the same issues as reported.

I also have the same issues reported in https://bugzilla.redhat.com/show_bug.cgi?id=847475 except that everything is running with 3.4.6-2.

Please tell me if you need more information or if I can test anything.
Comment 4 Taylor Smock 2012-09-15 13:09:46 EDT
I tested a F18 branched nightly (Fedora-18-Nightly-20120910.09-x86_64-Live-desktop.iso) with the 3.6.0-rc2 kernel, and my tablet's touchscreen worked (Fujitsu T731 with wacom touchscreen).

Kernel 3.4.x also works, but kernel 3.5.x currently does not work.

So, if the tablet features are really needed, don't delete the last 3.4.x kernel or get a 3.6.0-rc kernel.

Can everyone with this problem try the F18 alpha (on a live disk) when it comes out? I would really like confirmation that it isn't just my tablet PC that works again.
Comment 5 Jeremy Uchitel 2012-09-22 16:35:59 EDT
I have an HP TouchSmart tm2 with a wacom touchscreen and am experiencing the same problem with the recent 3.5.x kernels on F17. I'm currently running 3.5.4-1.

I tested the F18 Alpha live image today and the pen input works when booting that image.  Would be nice to have whatever fix is present in the 3.6.0-rc kernel backported to the 3.5.x series on F17.
Comment 6 Daniel Laczi 2012-09-26 19:42:15 EDT
The touchscreen of my ThinkPad X220 Tablet is working with F18 Alpha too.
Comment 7 Jeremy Uchitel 2012-09-30 08:46:32 EDT
After running the F18-Alpha live image, I figured it shouldn't be too much trouble to isolate the changes to the wacom driver.  I think I've winnowed it down to the crucial changes in 3.6.0-rc2 kernel that allow the touch screen to work again.  I've pulled those into a patch that works just fine on the 3.5.4-1.fc17 kernel.

I've never submitted a patch before, but if anyone wants to try it out, I am attaching it here.  So, if anyone wants to try it out, you can download the patch, compile a custom 3.5 series kernel in F17 and give it a go.  It works for me.
Comment 8 Jeremy Uchitel 2012-09-30 08:47:39 EDT
Created attachment 619427 [details]
Fixes from 3.6.0-rc2 to restore wacom touch screen functionality in 3.5
Comment 9 Josh Boyer 2012-10-01 10:29:22 EDT
(In reply to comment #8)
> Created attachment 619427 [details]
> Fixes from 3.6.0-rc2 to restore wacom touch screen functionality in 3.5

That looks identical to upstream

commit ea2e60244573a9204c8cee9b4fb181106784c617
Author: Ping Cheng <pinglinux@gmail.com>
Date:   Tue Jun 12 00:14:12 2012 -0700

    Input: wacom - rearrange type enum
    
    So we can simplify a few type related if statements
    
    Signed-off-by: Ping Cheng <pingc@wacom.com>
    Acked-by: Chris Bagwell <chris@cnpbagwell.com>
    Reviewed-by: Jason Gerecke <killertofu@gmail.com>
    Signed-off-by: Dmitry Torokhov <dtor@mail.ru>

Are you sure that is the only patch you need to get this working on 3.5?
Comment 10 Jeremy Uchitel 2012-10-01 15:58:54 EDT
(In reply to comment #9)

> That looks identical to upstream

Probably so!  I wasn't sure how to isolate the commits in git from upstream and just worked from doing a diff of the 3.5.4-1 and 3.6.0-rc2 source.

> Are you sure that is the only patch you need to get this working on 3.5?

Yes.  I updated to 3.5.4-2 and lost the touch screen support.  I just applied the patch against a fresh download of kernel-3.5.4-2.fc17.src.rpm, built and installed the kernel packages, and have a working touch screen again.
Comment 11 Jeremy Uchitel 2012-10-02 04:07:11 EDT
(In reply to comment #9)

> That looks identical to upstream
> 
> commit ea2e60244573a9204c8cee9b4fb181106784c617
> 
> Are you sure that is the only patch you need to get this working on 3.5?

Now that I see the actual commit, I think that yes, those changes to wacom_wac.c and wacom_wac.h were also present in the original diff that I ran against the wacom driver code.  There were several additional changes.  Because I was ignorant of the actual kernel commit, I kept to the idea that small patches are best and removed all of the diffs that looked like they were irrelevant to fixing my touch screen resulting in only the patch to wacom_sys.c.

My tablet works with only this patch, but others may need more.
Comment 12 Josh Boyer 2012-10-02 10:49:41 EDT
(In reply to comment #11)
> (In reply to comment #9)
> 
> > That looks identical to upstream
> > 
> > commit ea2e60244573a9204c8cee9b4fb181106784c617
> > 
> > Are you sure that is the only patch you need to get this working on 3.5?
> 
> Now that I see the actual commit, I think that yes, those changes to
> wacom_wac.c and wacom_wac.h were also present in the original diff that I
> ran against the wacom driver code.  There were several additional changes. 
> Because I was ignorant of the actual kernel commit, I kept to the idea that
> small patches are best and removed all of the diffs that looked like they
> were irrelevant to fixing my touch screen resulting in only the patch to
> wacom_sys.c.
> 
> My tablet works with only this patch, but others may need more.

I'll get a scratch kernel build with that commit added for testing.
Comment 13 Josh Boyer 2012-10-02 11:30:16 EDT
When this completes building, please test:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4551071
Comment 14 Jeremy Uchitel 2012-10-02 18:25:53 EDT
(In reply to comment #13)
> When this completes building, please test:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=4551071

Works for me.
Comment 15 Josh Boyer 2012-10-02 19:12:16 EDT
(In reply to comment #14)
> (In reply to comment #13)
> > When this completes building, please test:
> > 
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=4551071
> 
> Works for me.

Excellent.  Ryan and others, if you could confirm that would be great.
Comment 16 Daniel Laczi 2012-10-03 07:26:20 EDT
(In reply to comment #15)
> (In reply to comment #14)
> > (In reply to comment #13)
> > > When this completes building, please test:
> > > 
> > > http://koji.fedoraproject.org/koji/taskinfo?taskID=4551071
> > 
> > Works for me.
> 
> Excellent.  Ryan and others, if you could confirm that would be great.

Works here as well. Thanks.
Comment 17 Josh Boyer 2012-10-03 08:38:34 EDT
That commit was included in the 3.5.5 stable kernel update.  It should be fixed in the build that will hit updates-testing.  The updates system will leave a comment here when it is in the repos.
Comment 18 Fedora Update System 2012-10-03 08:39:39 EDT
kernel-3.5.5-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.5.5-1.fc17
Comment 19 Fedora Update System 2012-10-03 19:56:27 EDT
Package kernel-3.5.5-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.5.5-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15323/kernel-3.5.5-1.fc17
then log in and leave karma (feedback).
Comment 20 Jeremy Uchitel 2012-10-04 12:05:03 EDT
(In reply to comment #19)
> Package kernel-3.5.5-1.fc17:
> * should fix your issue,
> * was pushed to the Fedora 17 testing repository,
> * should be available at your local mirror within two days.

I have tested the kernel-3.5.5-1.fc17 package and can confirm that it works for me.  Thanks Josh, for getting this pushed so quickly!
Comment 21 Daniel Laczi 2012-10-04 13:14:17 EDT
Works for me, too. Thank you!
Comment 22 Fedora Update System 2012-10-08 07:45:27 EDT
kernel-3.5.6-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.5.6-1.fc17
Comment 23 Ryan H. Lewis (rhl) 2012-10-08 11:03:28 EDT
A bit late, but it works for me.
Comment 24 Donato 2012-10-09 16:28:37 EDT
my tablet lenovo x220 still does not work!
Comment 25 Donato 2012-10-10 04:40:01 EDT
(In reply to comment #24)
> my tablet lenovo x220 still does not work!

I solved with kernel 3.6.0-3 from fc18
Comment 26 Josh Boyer 2012-10-10 11:14:59 EDT
(In reply to comment #22)
> kernel-3.5.6-1.fc17 has been submitted as an update for Fedora 17.
> https://admin.fedoraproject.org/updates/kernel-3.5.6-1.fc17

Not sure why bodhi didn't close the bug.
Comment 27 Bahtiar `kalkin` Gadimov 2012-10-12 04:03:55 EDT
I have a lenovo thinkpad x220 tablet. I tried the 3.5.6-1 and 3.6.1-1 versions of the kernel. Wacom still doesn't work.
Comment 28 Daniel Laczi 2012-10-12 14:09:36 EDT
I'm currently running the 3.6.1-1.fc17.x86_64 kernel on my Thinkpad X220 Tablet and everything is fine...
Comment 29 Bahtiar `kalkin` Gadimov 2012-10-14 06:46:41 EDT
Strange, it just started to work. As i booted my thinkpad it didn't work, after some time using it i suspended it. After resuming the wacom tablet started to work. Strange :-/

Note You need to log in before you can comment on or make changes to this bug.