This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 8476 - Cannot print to HP-UX print server if "Suppress Headers" set
Cannot print to HP-UX print server if "Suppress Headers" set
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: lpr (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-14 14:50 EST by ken_laird
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-18 15:52:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ken_laird 2000-01-14 14:50:37 EST
If you create a remote printer with the "Suppress Headers" option set and
point it to an HP-UX print server, jobs you print will be deposited on the
print server but will not print unless the lp scheduler is stopped and
restarted.  Restarting the scheduler for every job is, obviously not a
viable workaround.

The problem is at line 862 in the file printjob.c in the package lpr-0.41.
That line suppresses the 'H' (source host) line from the control file.
According to RFC 1179, the Host name command MUST be included in the
control file.

I can't speak for other lp spoolers, but HP-UX 10.20's spooler enforces
that requirement.

Suppressing the header is not a good idea in general for remote printers
since there needs to be a way to identify the job owners; however, that is
the default setting in printtool and didn't make a difference in Redhat
Linux 6.0.

The workaround, until a bug fix is issued, is to not use the Suppress
Headers option for remote printers.
Comment 1 Bill Nottingham 2000-01-18 15:52:59 EST
This has been fixed in the various errata lpr releases.

Note You need to log in before you can comment on or make changes to this bug.