Bug 847683 - repoclosure failure on 18 Alpha TC4 DVDs (fatrat)
repoclosure failure on 18 Alpha TC4 DVDs (fatrat)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
18
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
AcceptedBlocker
: Reopened
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-08-13 05:34 EDT by Andre Robatino
Modified: 2014-03-16 23:31 EDT (History)
5 users (show)

See Also:
Fixed In Version: fatrat-1.2.0-0.7.beta2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-04 15:43:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2012-08-13 05:34:34 EDT
Description of problem:
i386 DVD:

package: 1:fatrat-1.2.0-0.5.beta1.fc18.i686 from myrepo
  unresolved deps: 
     libboost_thread-mt.so.1.48.0
     libboost_system-mt.so.1.48.0
     libboost_filesystem-mt.so.1.48.0
     libboost_date_time-mt.so.1.48.0

x86_64 DVD:

package: 1:fatrat-1.2.0-0.5.beta1.fc18.x86_64 from myrepo
  unresolved deps: 
     libboost_thread-mt.so.1.48.0()(64bit)
     libboost_system-mt.so.1.48.0()(64bit)
     libboost_filesystem-mt.so.1.48.0()(64bit)
     libboost_date_time-mt.so.1.48.0()(64bit)

Version-Release number of selected component (if applicable):
18 Alpha TC1
Comment 1 Jan Vcelak 2012-08-13 05:54:23 EDT
pion-net and fatrat need rebuild, however I would like to rebase pion before.
Comment 2 Andre Robatino 2012-08-16 00:55:33 EDT
Still broken in 18 Alpha TC2.
Comment 3 Adam Williamson 2012-08-16 15:35:53 EDT
Discussed at 2012-08-16 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-08-16/f18-alpha-blocker-review-3.2012-08-16-16.00.html . Accepted as a blocker per criterion "There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install".
Comment 4 Andre Robatino 2012-08-16 22:51:08 EDT
Still broken in 18 Alpha TC3.
Comment 5 Adam Williamson 2012-08-17 16:58:29 EDT
Jan: you could request a buildroot override for the new pion-net build, rebuild fatrat against it, and then edit fatrat into the same update request.
Comment 6 Jan Vcelak 2012-08-20 07:34:59 EDT
FatRat does not build with new boost and pion-net. I 'm working on it right now.
Comment 7 Fedora Update System 2012-08-20 10:31:27 EDT
fatrat-1.2.0-0.6.beta2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fatrat-1.2.0-0.6.beta2.fc18
Comment 8 Fedora Update System 2012-08-20 15:50:11 EDT
Package fatrat-1.2.0-0.6.beta2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fatrat-1.2.0-0.6.beta2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12305/fatrat-1.2.0-0.6.beta2.fc18
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-08-23 00:30:34 EDT
Package fatrat-1.2.0-0.7.beta2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fatrat-1.2.0-0.7.beta2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12305/fatrat-1.2.0-0.7.beta2.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-08-31 02:45:34 EDT
fatrat-1.2.0-0.7.beta2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Andre Robatino 2012-08-31 05:03:50 EDT
Broken in 18 Alpha TC4. Apparently the fixed version was not included.

i386:
package: 1:fatrat-1.2.0-0.5.beta1.fc18.i686 from myrepo
  unresolved deps: 
     libboost_thread-mt.so.1.48.0
     libboost_system-mt.so.1.48.0
     libboost_filesystem-mt.so.1.48.0
     libboost_date_time-mt.so.1.48.0

x86_64:
package: 1:fatrat-1.2.0-0.5.beta1.fc18.x86_64 from myrepo
  unresolved deps: 
     libboost_thread-mt.so.1.48.0()(64bit)
     libboost_system-mt.so.1.48.0()(64bit)
     libboost_filesystem-mt.so.1.48.0()(64bit)
     libboost_date_time-mt.so.1.48.0()(64bit)
Comment 12 Jan Vcelak 2012-08-31 05:22:45 EDT
Andre, please, read more carefully:

> fatrat-1.2.0-0.7.beta2.fc18 has been pushed to the Fedora 18 stable repository.

And that build is fixed indeed:
http://koji.fedoraproject.org/koji/rpminfo?rpmID=3314069

> libboost_date_time-mt.so.1.50.0()(64bit)
> libboost_filesystem-mt.so.1.50.0()(64bit)
> libboost_system-mt.so.1.50.0()(64bit)
> libboost_thread-mt.so.1.50.0()(64bit)

You will have to wait for the next compose.
Comment 13 Andre Robatino 2012-08-31 05:34:33 EDT
I did read carefully (note my statement "Apparently the fixed version was not included."). But there does need to be an open bug somewhere for the TC4 repoclosure failure. Do I need to open a separate one?
Comment 14 Andre Robatino 2012-08-31 12:27:00 EDT
Reopening and assigning to distribution since there needs to be an open bug for the TC4 repoclosure failure.
Comment 15 Andre Robatino 2012-09-01 00:51:24 EDT
fatrat was not included in the 18 Alpha TC5 DVD at all.
Comment 16 Adam Williamson 2012-09-04 15:43:52 EDT
this should not be an issue in future composes now that the fixed version has been pushed stable - the reason the older version was pulled in to TC4 is that it had Provides: that the newer version didn't. When the older version isn't available any more, things should be OK.

Note You need to log in before you can comment on or make changes to this bug.