Bug 847683 - repoclosure failure on 18 Alpha TC4 DVDs (fatrat)
Summary: repoclosure failure on 18 Alpha TC4 DVDs (fatrat)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 18
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F18Alpha, F18AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2012-08-13 09:34 UTC by Andre Robatino
Modified: 2014-03-17 03:31 UTC (History)
5 users (show)

Fixed In Version: fatrat-1.2.0-0.7.beta2.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-04 19:43:52 UTC


Attachments (Terms of Use)

Description Andre Robatino 2012-08-13 09:34:34 UTC
Description of problem:
i386 DVD:

package: 1:fatrat-1.2.0-0.5.beta1.fc18.i686 from myrepo
  unresolved deps: 
     libboost_thread-mt.so.1.48.0
     libboost_system-mt.so.1.48.0
     libboost_filesystem-mt.so.1.48.0
     libboost_date_time-mt.so.1.48.0

x86_64 DVD:

package: 1:fatrat-1.2.0-0.5.beta1.fc18.x86_64 from myrepo
  unresolved deps: 
     libboost_thread-mt.so.1.48.0()(64bit)
     libboost_system-mt.so.1.48.0()(64bit)
     libboost_filesystem-mt.so.1.48.0()(64bit)
     libboost_date_time-mt.so.1.48.0()(64bit)

Version-Release number of selected component (if applicable):
18 Alpha TC1

Comment 1 Jan Vcelak 2012-08-13 09:54:23 UTC
pion-net and fatrat need rebuild, however I would like to rebase pion before.

Comment 2 Andre Robatino 2012-08-16 04:55:33 UTC
Still broken in 18 Alpha TC2.

Comment 3 Adam Williamson 2012-08-16 19:35:53 UTC
Discussed at 2012-08-16 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-08-16/f18-alpha-blocker-review-3.2012-08-16-16.00.html . Accepted as a blocker per criterion "There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install".

Comment 4 Andre Robatino 2012-08-17 02:51:08 UTC
Still broken in 18 Alpha TC3.

Comment 5 Adam Williamson 2012-08-17 20:58:29 UTC
Jan: you could request a buildroot override for the new pion-net build, rebuild fatrat against it, and then edit fatrat into the same update request.

Comment 6 Jan Vcelak 2012-08-20 11:34:59 UTC
FatRat does not build with new boost and pion-net. I 'm working on it right now.

Comment 7 Fedora Update System 2012-08-20 14:31:27 UTC
fatrat-1.2.0-0.6.beta2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fatrat-1.2.0-0.6.beta2.fc18

Comment 8 Fedora Update System 2012-08-20 19:50:11 UTC
Package fatrat-1.2.0-0.6.beta2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fatrat-1.2.0-0.6.beta2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12305/fatrat-1.2.0-0.6.beta2.fc18
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2012-08-23 04:30:34 UTC
Package fatrat-1.2.0-0.7.beta2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fatrat-1.2.0-0.7.beta2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12305/fatrat-1.2.0-0.7.beta2.fc18
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2012-08-31 06:45:34 UTC
fatrat-1.2.0-0.7.beta2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Andre Robatino 2012-08-31 09:03:50 UTC
Broken in 18 Alpha TC4. Apparently the fixed version was not included.

i386:
package: 1:fatrat-1.2.0-0.5.beta1.fc18.i686 from myrepo
  unresolved deps: 
     libboost_thread-mt.so.1.48.0
     libboost_system-mt.so.1.48.0
     libboost_filesystem-mt.so.1.48.0
     libboost_date_time-mt.so.1.48.0

x86_64:
package: 1:fatrat-1.2.0-0.5.beta1.fc18.x86_64 from myrepo
  unresolved deps: 
     libboost_thread-mt.so.1.48.0()(64bit)
     libboost_system-mt.so.1.48.0()(64bit)
     libboost_filesystem-mt.so.1.48.0()(64bit)
     libboost_date_time-mt.so.1.48.0()(64bit)

Comment 12 Jan Vcelak 2012-08-31 09:22:45 UTC
Andre, please, read more carefully:

> fatrat-1.2.0-0.7.beta2.fc18 has been pushed to the Fedora 18 stable repository.

And that build is fixed indeed:
http://koji.fedoraproject.org/koji/rpminfo?rpmID=3314069

> libboost_date_time-mt.so.1.50.0()(64bit)
> libboost_filesystem-mt.so.1.50.0()(64bit)
> libboost_system-mt.so.1.50.0()(64bit)
> libboost_thread-mt.so.1.50.0()(64bit)

You will have to wait for the next compose.

Comment 13 Andre Robatino 2012-08-31 09:34:33 UTC
I did read carefully (note my statement "Apparently the fixed version was not included."). But there does need to be an open bug somewhere for the TC4 repoclosure failure. Do I need to open a separate one?

Comment 14 Andre Robatino 2012-08-31 16:27:00 UTC
Reopening and assigning to distribution since there needs to be an open bug for the TC4 repoclosure failure.

Comment 15 Andre Robatino 2012-09-01 04:51:24 UTC
fatrat was not included in the 18 Alpha TC5 DVD at all.

Comment 16 Adam Williamson 2012-09-04 19:43:52 UTC
this should not be an issue in future composes now that the fixed version has been pushed stable - the reason the older version was pulled in to TC4 is that it had Provides: that the newer version didn't. When the older version isn't available any more, things should be OK.


Note You need to log in before you can comment on or make changes to this bug.