Bug 847726 - ibus uses same input method for each application
ibus uses same input method for each application
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
: i18n, Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 07:19 EDT by Danishka Navin
Modified: 2013-11-25 23:14 EST (History)
10 users (show)

See Also:
Fixed In Version: ibus-1.5.4-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 01:43:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Danishka Navin 2012-08-13 07:19:22 EDT
Description of problem:

After enabling ibus and type some thing on an application, the ibus use same input method for other applications as well.

For example, if i type in Sinhala on LibreOffice (using ibus-sayura), gnome-terminal, firefox, etc every other application use ibus-sayura instead of en_US.

in previous versions we had that flexibility of using different IMs for different applications at once.

Version-Release number of selected component (if applicable):

ibus-1.4.99.20120428-2.fc17.x86_64

How reproducible:


Steps to Reproduce:
1. Install ibus-sayura on Fedora 17
2. Enable ibus-sayura
3. Open Firefox and type using ibus-sayura
4. Now open gnome-terminal and type some thing 
  
Actual results:

sinhala characters will type on gnome-terminal 

Expected results:

As you did not select ibus-sayura for Gnome-terminal application, it should  type in English


Additional info:

Very negative feedback from the local community and it affect for the Fedora as most of end users not aware this issue came from the upstream.

Personal Comment:

I believe that upstream developer(s) should work on some other project instead sending a crappy application. OR some one should fork the ibus and start working on it for a target of making a better product for end users. The product features should be improved instead of reduce.
Comment 1 fujiwara 2012-08-13 21:36:31 EDT
Now the ibus switches XKB keymaps and input methods and XKB keymaps have the global status.
It may be similar with Mac OS and Chrome OS.
I had implemented the local status in f15 and f16 but the implementation would be complicated and now the latest ibus is implemented more simply to maintain the codes.

It would be the design to integrate ibus in gnome.
https://live.gnome.org/GnomeShell/Design/Guidelines/SystemStatus/InputLanguage
https://bugzilla.gnome.org/show_bug.cgi?id=641531#c63
Comment 2 Danishka Navin 2012-08-13 22:53:22 EDT
I am representing my local community and the current solution is really poor solution for languages which not support terminal.

may be its simple to maintain the code but its painful for enduser.

Do developers developing there application for end user or just for their own fun?
Comment 3 fujiwara 2012-08-13 23:02:41 EDT
(In reply to comment #2)
> I am representing my local community and the current solution is really poor
> solution for languages which not support terminal.

What is poor solution?

> Do developers developing there application for end user or just for their
> own fun?

Please don't express just your feeling but explain your problem.
Comment 4 Danishka Navin 2012-08-13 23:08:02 EDT
Do you that, now we do not need to hit several clicks to select an application on Gnome 3.x? it just mater of pressing the supper key and type the (part of) application name. therefore we really need less clicks. 

In FC15 and FC16 are really nice as we want to set the iBus only once. for example, I never hit Sinhala character on terminal or on the 'run' window comes after pressing alt+f2

I disagree with your comment "now the latest ibus is implemented more simply to maintain the codes", as your solution not fit on our requirement.
Comment 5 fujiwara 2012-08-13 23:14:10 EDT
(In reply to comment #4)
> Do you that, now we do not need to hit several clicks to select an
> application on Gnome 3.x? it just mater of pressing the supper key and type
> the (part of) application name. therefore we really need less clicks. 

Also why don't use use short cut keys to switch engines? The default shortcut key is Control+space till releasing Control key and it now works likes Alt+Tab window switcher.
Comment 6 Danishka Navin 2012-08-13 23:23:37 EDT
Control+space was working before and now, but most of the time when we going to start an application here is the process.

01. hit the alt+f2 
02. type the application name
03. application name not type in English as I was using Sinhala Input Method
04. press Esc and go back
05. turn off the iBus
06. hit alt+f2
07. type the application name

and if I want to write a letter in Sinhala 

08. change iBus to Sinhala

the above process is not just one time per day but earlier i never done beyond step 02 for none Sinhala support applications.

do you think this is easy to do all day?

Yes, I am writing with my feeling as I really fed up with this current solution and you never understand it. And local users also complaining on whats going on with Sinhala typing?

According to you the iBus is going to be a developer friendly but not user friendly.
Comment 7 fujiwara 2012-08-13 23:33:49 EDT
(In reply to comment #6)
> Control+space was working before and now, but most of the time when we going
> to start an application here is the process.
> 
> 01. hit the alt+f2 
> 02. type the application name
> 03. application name not type in English as I was using Sinhala Input Method
> 04. press Esc and go back
> 05. turn off the iBus
> 06. hit alt+f2
> 07. type the application name
> 
> and if I want to write a letter in Sinhala 
> 
> 08. change iBus to Sinhala
> 
> the above process is not just one time per day but earlier i never done
> beyond step 02 for none Sinhala support applications.
> 
> do you think this is easy to do all day?

Yes, I think it's easy and probably I use the same situation every day and I don't think it's a trouble from my daily usage since I just type Control+Space to switch an engine or switch back to an engine.

> 
> Yes, I am writing with my feeling as I really fed up with this current
> solution and you never understand it. And local users also complaining on
> whats going on with Sinhala typing?
> 
> According to you the iBus is going to be a developer friendly but not user
> friendly.

I don't think so.
Probably I think if you'd like to expand the discussion, this would not be a good place.
Probably It would be good to send ibus-user@googlegroups.com or desktop-devel-list@gnome.org while maybe I think people don't agree with your thought.
Comment 8 Parag Nemade 2012-08-13 23:47:23 EDT
The ibus integration into gnome is a upstream feature https://live.gnome.org/ThreePointFive/Features/IBus

If any changes are needed that need to be discussed on desktop-devel-list@gnome.org list. Fedora is just shipping the gnome packages which is following this ibus integration.
Comment 9 Danishka Navin 2012-08-14 00:23:00 EDT
fujiwara,
While you agree with that issue but you do not say its an issue as you are not willing to say this solution implemented with a weak point. 

Most of NOC people not agreed with the time taken to update a fedora box as they do not feel any delay as they have a good connectivity. But there are some people still live in the world with really poor connectivity.
This issue is similar to above example, as you do not feel the issue.

Just give both systems to an ordinary user and get a none bias feedback.

For example;
Do you know that some of people think Sinhala and Tamil is not available in the list as they have to click and expand the list (while setting iBus preferences).

But some one made the list shorter and its much easier for few European languages where user can directly select.


At least there should be a away to lock down iBus for selected applications where user does not need to hit any keys once they open an application.

feel free to share this on any mailing list.

parag, 
thanks for the info but i won't work on this issue here after.
Comment 10 Harshula Jayasuriya 2012-08-14 00:59:18 EDT
Fujiwara, what was the justification removing the checkbox option which allowed different IMs in different windows/applications? Was there any analysis done on user requirements?
Comment 11 fujiwara 2012-08-14 03:08:37 EDT
(In reply to comment #10)
> Fujiwara, what was the justification removing the checkbox option which
> allowed different IMs in different windows/applications? Was there any
> analysis done on user requirements?

The checkbox was removed because the feature is no longer used in the latest ibus.
Other things are explained above and I said this would not be a good place to expand the discussions.
Comment 12 cnsturgeon2000 2013-06-05 00:56:06 EDT
I am on Linux Mint 15 now, the only reason keeping me off fedora is that no way I can setup the input method just for a single application. 

If I need Chinese, Japanese, whatever, I would simply ctrl-space, I don't need every single application comes with Chinese input by default, for example, when typing these text.

Why Ubuntu / Debian / Linux Mint can have such a setting, and Fedora can't?
Comment 13 fujiwara 2013-06-05 01:17:52 EDT
(In reply to cnsturgeon2000 from comment #12)
> Why Ubuntu / Debian / Linux Mint can have such a setting, and Fedora can't?

Because they use the old ibus.
Comment 14 cnsturgeon2000 2013-06-05 20:41:00 EDT
(In reply to fujiwara from comment #13)
> (In reply to cnsturgeon2000 from comment #12)
> > Why Ubuntu / Debian / Linux Mint can have such a setting, and Fedora can't?
> 
> Because they use the old ibus.

Even scim / xim was changed to such a setting on Fedora too? With my experience, Chinese input method is enabled across all applications even using scim. If this is true, just simply silly, software is made to make people's lives easy not the opposite.

Mac OS X has the same behaviour, so I don't like it. I choose Linux because I have options. Why limit people with this, even on Windows, I still can choose when I can have the Chinese input method enabled.
Comment 15 Jens Petersen 2013-06-05 22:25:54 EDT
Global IM state may make sense on consumer like OSX but I am not
so sure now about Linux/workstations.  I think at least we should
support local IM state and maybe it should even be default.
Comment 16 cnsturgeon2000 2013-06-06 00:51:09 EDT
(In reply to Jens Petersen from comment #15)
> Global IM state may make sense on consumer like OSX but I am not
> so sure now about Linux/workstations.  I think at least we should
> support local IM state and maybe it should even be default.

Thank you very much for. As a fan of Fedora, I really appreciate it.
Comment 17 Harshula Jayasuriya 2013-06-29 21:23:07 EDT
FYI, I was playing with Gnome 3.8 (distro != Fedora):

1) Go to Settings
2) Click on "Region & Language"
3) Click on "Options" that is beside the heading "Input Sources"
4) You can select between:
   * "Use the same source for all windows"
   * "Allow different sources for each window"

I haven't tested it yet though.
Comment 18 Jens Petersen 2013-07-04 21:46:50 EDT
Thanks Hash for that comment.

I think I have tried it and it did work per window.

So moving this to F18 for now.
Comment 19 Jens Petersen 2013-07-04 21:47:29 EDT
But I guess non-Gnome users may still want this for other desktops.
Comment 20 Harshula Jayasuriya 2013-07-07 21:46:47 EDT
Verified on Fedora 19 that the following options work:
* "Use the same source for all windows"
* "Allow different sources for each window"

(In reply to Jens Petersen from comment #19)
> But I guess non-Gnome users may still want this for other desktops.

That's a tough one. Has there been a paradigm shift where it is the responsibility of the desktop environment to provide this option as opposed to the IM Framework?
Comment 22 Fedora Update System 2013-09-23 23:03:48 EDT
ibus-1.5.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-17327/ibus-1.5.4-1.fc20
Comment 23 Fedora Update System 2013-09-23 23:05:15 EDT
ibus-1.5.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-17357/ibus-1.5.4-1.fc19
Comment 24 Fedora Update System 2013-09-23 23:06:03 EDT
ibus-1.5.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-17371/ibus-1.5.4-1.fc18
Comment 25 Fedora Update System 2013-09-28 21:39:53 EDT
ibus-1.5.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Fedora Update System 2013-09-29 20:42:58 EDT
ibus-1.5.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2013-10-04 04:57:47 EDT
ibus-1.5.4-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-1.5.4-2.fc19
Comment 28 Fedora Update System 2013-10-04 04:58:25 EDT
ibus-1.5.4-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-1.5.4-2.fc18
Comment 29 Fedora Update System 2013-10-04 04:59:01 EDT
ibus-1.5.4-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-1.5.4-2.fc20
Comment 30 Fedora Update System 2013-10-04 21:41:04 EDT
Package ibus-1.5.4-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.5.4-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18298/ibus-1.5.4-2.fc20
then log in and leave karma (feedback).
Comment 31 Fedora Update System 2013-11-10 01:43:00 EST
ibus-1.5.4-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 32 Fedora Update System 2013-11-25 23:05:48 EST
ibus-1.5.4-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 33 Fedora Update System 2013-11-25 23:14:03 EST
ibus-1.5.4-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.