Bug 847736 - Virtualization icon is assigned to servers with nither Virtualizaiton or Virtualization platform entitlement.
Virtualization icon is assigned to servers with nither Virtualizaiton or Vir...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Dimitar Yordanov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 07:43 EDT by Dimitar Yordanov
Modified: 2012-09-21 09:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 08:27:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
System with Vitualization Icon but no Virtualization Entitlement (68.77 KB, image/png)
2012-08-13 07:44 EDT, Dimitar Yordanov
no flags Details

  None (edit)
Description Dimitar Yordanov 2012-08-13 07:43:19 EDT
Description of problem:
Virtualization icon is assigned to servers with nither  Virtualizaiton or Virtualization platform entitlement in case package "rhn-virtualization-host" is installed on the server.

The behaviour is different than on Satallite 5.4.1 therefor the issue is a regression.

In case a system is registred to Satallite 5.4.1 and this system has package "rhn-virtualization-host" installed but no Virtualizaiton or Virtualization platform entitlement assigned on WebUI this system has a regular icon. 
In case we upgrade this server to Satellite 5.5.0 then the icon of the server is changed to Virtualization icon.

Version-Release number of selected component (if applicable):
Satellite 550.

How reproducible:
100%

Steps to Reproduce:
1. Install rhn-virtualization-host package on a server.
2. service libvirtd start.
3. Register the Server to Satellite 550.
  
Actual results:
Virtualization icon  is assigned to the server on WebUI.

Expected results:
Normal icon  is assigned to the server on WebUI.

Additional info:
See attachement.
Comment 1 Dimitar Yordanov 2012-08-13 07:44:06 EDT
Created attachment 603969 [details]
System with Vitualization Icon but no Virtualization Entitlement
Comment 2 Tomas Lestach 2012-08-13 08:27:10 EDT
Any reason, why the BZ is reported against sat530?

This looks like an expected behavior, see Bug 805932 for more details.
Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.