Bug 847753 - Duplicate and contradicting "debug" statement in corosync.conf.example.udpu
Duplicate and contradicting "debug" statement in corosync.conf.example.udpu
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: corosync (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Steven Dake
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 08:57 EDT by Moritz Naumann
Modified: 2016-04-26 13:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-14 06:21:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritz Naumann 2012-08-13 08:57:07 EDT
Description of problem:
The source releases of corosync 2.0.1 and 1.4.3 contain the following in conf/corosync.conf.example.udpu:

logging {
...
	debug: on
	logfile: /var/log/cluster/corosync.log
	debug: off
...
}

My understanding is that these 'debug' statements contradict each other, and that only the last one applies. To me, contradictory statements in an example configuration file are problematic since they can irritate users who are trying to adopt this software. I recommend to fix this by removing the first occasion.

The Corosync website at http://corosync.org/doku.php?id=support suggests that bugs against the source / upstream release should be filed here against Fedora, so I'm doing this (without having verified whether this issue actually affects Fedora, too). The example configuration file is contained unmodified in ELRepo.

Version-Release number of selected component (if applicable):
1.4.3
Comment 1 Moritz Naumann 2012-08-13 09:06:38 EDT
q.v. http://elrepo.org/bugs/view.php?id=295
Comment 2 Moritz Naumann 2012-08-13 12:19:25 EDT
Please ignore (or delete) comment 1, this package is not in the ElRepo repository. Instead I'm adding a reference to the related bug report against CentOS 6.
Comment 3 Jan Friesse 2012-08-14 06:21:18 EDT
Commuted as 6f47c1716020a8c8197b8d2c4d9dec9bb9328c4e and 6459f2cda14360e659633571947c58cfc8572107. Closing as upstream.

Thanks for bug report.

Note You need to log in before you can comment on or make changes to this bug.