Bug 847778 - RFE: Have gluster volume delete clean up xattrs that are left behind from volume deletes.
RFE: Have gluster volume delete clean up xattrs that are left behind from vol...
Status: CLOSED DUPLICATE of bug 812214
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Amar Tumballi
Sudhir D
: FutureFeature
Depends On: 847411
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 10:09 EDT by Ben Turner
Modified: 2013-12-18 19:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 847411
Environment:
Last Closed: 2012-08-13 11:02:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Turner 2012-08-13 10:09:17 EDT
Description of problem:  When gluster volume delete is run and removes the volume it leaves behind xattrs that cause a gluster volume create to fail.

Version-Release number of selected component (if applicable):

glusterfs-server-3.3.0rhs-25.el6rhs.x86_64

How reproducible:

Every time.

Steps to Reproduce:
1.  Run gluster volume delete on a volume
2.  Try to create a new volume using the brick from a deleted volume
3.
  
Actual results:

***From the command line***
Create: 
[root@hp-dl380g7-1 distributed-volume-setup]# gluster volume create distributed-volume hp-dl380g7-1.gsslab.rdu.redhat.com:/brick1 hp-dl380g7-2.gsslab.rdu.redhat.com:/brick1 
Creation of volume distributed-volume has been successful. Please start the volume to access data.

Delete: 
[root@hp-dl380g7-1 distributed-volume-setup]# gluster volume delete distributed-volume 
Deleting volume will erase all information about the volume. Do you want to continue? (y/n) y Deleting volume distributed-volume has been successful

And create again: 
[root@hp-dl380g7-1 distributed-volume-setup]# gluster volume create distributed-volume hp-dl380g7-1.gsslab.rdu.redhat.com:/brick1 hp-dl380g7-2.gsslab.rdu.redhat.com:/brick1 
/brick1 or a prefix of it is already part of a volume

Expected results:

The xattrs are properly cleared so that a volume create can be executed without manually clearing them.

Additional info:
Comment 3 Ben Turner 2012-08-13 11:02:36 EDT

*** This bug has been marked as a duplicate of bug 812214 ***

Note You need to log in before you can comment on or make changes to this bug.