Bug 847783 - Build failure due to rdoc incompatibility
Build failure due to rdoc incompatibility
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-progressbar (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vít Ondruch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 10:29 EDT by Marc Savy
Modified: 2012-09-17 19:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 19:49:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Savy 2012-08-13 10:29:19 EDT
Description of problem:

Rawhide builds of rubygem-progressbar are failing:
https://koji.fedoraproject.org/koji/taskinfo?taskID=4384025

... MESSAGE:   cannot load such file -- rdoc/rd/block_parser

Log: 
http://kojipkgs.fedoraproject.org//work/tasks/4030/4384030/build.log

This seems to be related to the RDoc version now shipping. Even on F17 if you install the 0.9.0 gem directly you receive the same error message about rdoc (which can be bypassed by using --no-rdoc). By using a later version (e.g. 0.11.0), the problem has been resolved.

It might be worth considering bumping to the latest progressbar; there don't seem to be any breaking changes, and there have been numerous bug fixes.
Comment 1 Fedora Update System 2012-09-07 05:56:23 EDT
rubygem-progressbar-0.11.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rubygem-progressbar-0.11.0-1.fc18
Comment 2 Fedora Update System 2012-09-07 15:39:25 EDT
Package rubygem-progressbar-0.11.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rubygem-progressbar-0.11.0-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13572/rubygem-progressbar-0.11.0-1.fc18
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-09-17 19:49:08 EDT
rubygem-progressbar-0.11.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.