Bug 847785 - Quantum installation scripts for linux bridge do not set correct database parameters in the configuration file
Quantum installation scripts for linux bridge do not set correct database par...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
1.0 (Essex)
Unspecified Unspecified
high Severity high
: ga
: 1.0 Essex
Assigned To: Alan Pevec
Jaroslav Henner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 10:36 EDT by Gary Kotton
Modified: 2016-04-26 13:07 EDT (History)
3 users (show)

See Also:
Fixed In Version: openstack-quantum-2012.1-8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 11:45:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1377 normal SHIPPED_LIVE openstack-quantum bug fix update 2012-10-16 15:43:59 EDT

  None (edit)
Description Gary Kotton 2012-08-13 10:36:41 EDT
Description of problem:
When using the installation scripts quantum-node-setup and quantum-server-setup the quantum agent and the quantum service are unable to communicate with the database. 

Version-Release number of selected component (if applicable):
RH Essex


How reproducible:
Every time.

Steps to Reproduce:
1. Install quantum service package (openstack-quantum)
2. Install quntum linux bridge plugin (openstack-quantum-linuxbridge)
3. Run quantum-node-setup and quantum-server-setup. In the linux bridge plugin file. In the file /etc/quantum/plugins/linuxbridge/linuxbridge_conf.ini the following entry does not appear sql_connection
  
Actual results:
Quantum agent is unable to communicate with quantum server
Quantum server will lose all data after retsarting

Expected results:
It should all work :)

Additional info:
Comment 1 Gary Kotton 2012-08-13 10:38:47 EDT
The problem has already been addressed in Fedora:- https://koji.fedoraproject.org/koji/buildinfo?buildID=347429

Please note that the problem only occurs when the packging utility scripts are used for the deployment. This is not related to the Quantum code just to the configuration.
Comment 3 Jaroslav Henner 2012-08-28 07:53:16 EDT
[root@quantum-server ~]#  grep sql_conn /etc/quantum/plugins/linuxbridge/linuxbridge_conf.ini
# sql_connection = mysql://root:nova@127.0.0.1:3306/quantum_linux_bridge
sql_connection = mysql://quantum:quantum@quantum-server.lithium.../quantum_linux_bridge

[root@quantum-node ~]# grep sql_conn /etc/quantum/plugins/linuxbridge/linuxbridge_conf.ini
# sql_connection = mysql://root:nova@127.0.0.1:3306/quantum_linux_bridge
sql_connection = mysql://quantum:quantum@quantum-server.lithium/quantum_linux_bridge

... so far so good. I'm going to test whether all is talking together.
Comment 4 Jaroslav Henner 2012-08-28 10:41:32 EDT
I managed to get.
[root@quantum-node ~]# brctl show
bridge name	bridge id		STP enabled	interfaces
brqf827be69-e6		8000.52540055f210	no		eth1.1001
							tap0fbefbb8-82
VERIFIED
Comment 6 errata-xmlrpc 2012-10-16 11:45:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1377.html

Note You need to log in before you can comment on or make changes to this bug.