Bug 847803 - fileconflicts failure on 18 Alpha TC1 DVDs (libpng/libpng12)
fileconflicts failure on 18 Alpha TC1 DVDs (libpng/libpng12)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libpng12 (Show other bugs)
18
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-08-13 11:38 EDT by Andre Robatino
Modified: 2013-07-02 23:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 22:00:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2012-08-13 11:38:49 EDT
Description of problem:
Ignoring the samba/samba4 output associated with bug 820472, the only fileconflicts output from https://fedoraproject.org/wiki/QA:Testcase_Mediakit_FileConflicts is

i386 DVD:

== Package conflicts ==
2:libpng-devel-1.5.12-1.fc18.i686
libpng12-devel-1.2.50-1.fc18.i686

x86_64 DVD:
2:libpng-devel-1.5.12-1.fc18.x86_64
libpng12-devel-1.2.50-1.fc18.x86_64

Version-Release number of selected component (if applicable):
18 Alpha TC1
Comment 1 Andre Robatino 2012-08-13 11:43:44 EDT
Sorry, that should read

i386 DVD:

== Package conflicts ==
2:libpng-devel-1.5.12-1.fc18.i686
libpng12-devel-1.2.50-1.fc18.i686

x86_64 DVD:

== Package conflicts ==
2:libpng-devel-1.5.12-1.fc18.x86_64
libpng12-devel-1.2.50-1.fc18.x86_64
Comment 2 Tom Lane 2012-08-13 12:03:33 EDT
libpng12-devel specifically bears the notation "Conflicts: libpng-devel", and there really is not a way around that since they each need to provide /usr/include/png.h.  So my opinion is that this is not a bug.  If it's a problem for making the DVDs, I would suggest leaving libpng12-devel off the DVDs.
Comment 3 Adam Williamson 2012-08-13 22:00:59 EDT
Nope, if there's an explicit Conflicts: tag then it does not violate the release criteria. Andre, can you take a quick look when coming across these in future to see if there's an explicit Conflicts: tag in either package before filing a bug? Thanks!
Comment 4 Adam Williamson 2012-08-13 22:02:35 EDT
Andre: note that the potential_conflicts.py script shows File Conflicts and Package Conflicts separately; if I'm reading it right, I think only things listed under File Conflicts are potentially problematic. I don't think things listed under Package Conflicts are a problem.
Comment 5 Andre Robatino 2012-08-16 00:44:31 EDT
(In reply to comment #4)
> Andre: note that the potential_conflicts.py script shows File Conflicts and
> Package Conflicts separately; if I'm reading it right, I think only things
> listed under File Conflicts are potentially problematic. I don't think
> things listed under Package Conflicts are a problem.

The current version of the page says

 Expected Results

    The potential_conflict.py script completes successfully
    No package or file conflicts were detected for packages included in the media kit 

In an earlier version of the page, Rhe said "No file conflicts were detected for packages included in the media kit, unless the conflicting packages also have explicit Conflicts: tags", but then reverted it (see https://fedoraproject.org/w/index.php?title=QA:Testcase_Mediakit_FileConflicts&diff=prev&oldid=193334 ). In any case I changed my fileconflicts results for TC1 to PASS, and the result is the same for TC2.

Note You need to log in before you can comment on or make changes to this bug.