Bug 847805 - [MLA] User with DiskCreator role can not create disks in Admin Portal.
[MLA] User with DiskCreator role can not create disks in Admin Portal.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Oved Ourfali
Dafna Ron
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 11:41 EDT by Leonid Natapov
Modified: 2016-02-10 14:13 EST (History)
10 users (show)

See Also:
Fixed In Version: si15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:04:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Natapov 2012-08-13 11:41:38 EDT
[MLA] User with DiskCreator role can not create disks in Admin Portal.
Getting "User not authorized error".

Scenario:
User with permissions on DataCenter (or SD or Cluster) and DiskCreator role. User also have some admin role in order to be able to log into admin portal.

User can not create disks (floating disks) despite the DiskCreator role.

AddDisk function receives VmID as parameter and in case when there is no VM (floating disks) it expects the VmID to be null. But VmID is not null (this is the bug). In UserPortal this won't happen because there is always a VM when creating a disk. No possibility to create floating disks in UserPortal.
Comment 1 Oved Ourfali 2012-08-14 01:14:50 EDT
Commit: 0abe9f2e7ab5326c043b620fb0e775dfd5f7a2a7

http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=0abe9f2e7ab5326c043b620fb0e775dfd5f7a2a7
Comment 4 Dafna Ron 2012-09-02 10:42:35 EDT
checked on si16. 
i was able to create a floating disk from the UI but I created a VM when my user had UserRole and I was unable to create a disk for the vm after speaking to oved, we need to give VmManager to the user.
but this bug is verified since we can create floating disks with DiskCreator.

Note You need to log in before you can comment on or make changes to this bug.