Bug 847831 - kickstart boot fails with %include file generated by %pre
kickstart boot fails with %include file generated by %pre
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 13:11 EDT by Orion Poplawski
Modified: 2013-01-10 01:53 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 12:40:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of vm failed boot (38.88 KB, image/png)
2012-08-13 13:11 EDT, Orion Poplawski
no flags Details
Screenshot of failed boot (39.14 KB, image/png)
2012-08-16 00:38 EDT, Orion Poplawski
no flags Details
anaconda screenshot (37.18 KB, image/png)
2012-08-17 11:18 EDT, Orion Poplawski
no flags Details
anaconda screenshot (21.14 KB, image/png)
2012-09-05 12:41 EDT, Orion Poplawski
no flags Details
working kickstart with %include url (952 bytes, text/plain)
2012-10-15 10:57 EDT, Kamil Páral
no flags Details
kickstart with %Include generated by %pre (1.16 KB, text/plain)
2012-10-15 12:40 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2012-08-13 13:11:44 EDT
Created attachment 604054 [details]
Screen shot of vm failed boot

Description of problem:

Using koan to try to install F18-Alpha-TC1 vm fails.  See attached screen shot.  Some perhaps relevant error messages:

dracut-pre-udev[214]: //lib/dracut/hooks/pre-udev/40-kickstart-gengrules.sh: line 7: wait_for_kickstart: command not found
dracut-initqueue[290]: Warning: Could not boot.
dracut-cmdline[57]: //lib/dracut/hooks/cmdline/24-anaconda-modprobe.sh: line 20: basename: command not found
dracut-cmdline[57]: FATAL: Module iscsi_tcp not found.
dracut-cmdline[57]: FATAL: Module iscsi_ibft not found.
dracut-cmdline[57]: FATAL: Module sha256 not found.
Comment 1 Adam Williamson 2012-08-13 22:34:47 EDT
Probably the same as 847644, right?
Comment 2 Orion Poplawski 2012-08-13 23:08:56 EDT
Quite possibly has the same solution, but they are different boot paths.  I'll let the anaconda folks decide.  Otherwise let's wait until the next compose.
Comment 3 Orion Poplawski 2012-08-16 00:38:09 EDT
Created attachment 604782 [details]
Screenshot of failed boot

Different, but still no go with Alpha TC2.  Sorry, but just too hard to transcribe on my netbook.  Will try do so in the morning.
Comment 4 Orion Poplawski 2012-08-16 10:50:39 EDT
dracut-pre-udev[206]: //lib/dracut/hooks/pre-udev/40-kickstart-gengrules.sh: line 7: wait_for_kickstart: command not found
dracut-initqueue[286]: /lib/dracut/hooks/initqueue/settled/00-anaconda-ks-sendheaders.sh: line 16: set_http_header: command not found
Comment 5 Adam Williamson 2012-08-16 12:20:13 EDT
That now seems to be specific to kickstart installs, so let's keep the bug open.
Comment 6 Jesse Keating 2012-08-16 12:52:01 EDT
This looks like another case of a missing sourceing of necessary library.  Dracut changed recently and now imports are carrying over from one phase to the next.  Should be a simple fix, I'll work up a patch soon, if wwoods doesn't beat me to it.
Comment 7 Adam Williamson 2012-08-16 13:05:51 EDT
Proposing as a Beta blocker; kickstart is in the Beta criteria.
Comment 8 Jesse Keating 2012-08-16 14:09:07 EDT
Patch posted.
Comment 9 Fedora Update System 2012-08-16 18:07:05 EDT
anaconda-18.6-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.6-1.fc18
Comment 10 Fedora Update System 2012-08-17 02:19:58 EDT
Package anaconda-18.6-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.6-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12095/anaconda-18.6-1.fc18
then log in and leave karma (feedback).
Comment 11 Orion Poplawski 2012-08-17 11:18:55 EDT
Created attachment 605206 [details]
anaconda screenshot

WIth TC3, the set_http_header message is gone, but the wait_for_kickstart line is still there and it still fails to boot.
Comment 12 Jesse Keating 2012-08-17 13:28:09 EDT
New patch posted.
Comment 13 Fedora Update System 2012-08-21 07:39:31 EDT
anaconda-18.6-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Orion Poplawski 2012-08-21 11:13:12 EDT
Reopening.  Not yet fixed.
Comment 15 Jesse Keating 2012-08-21 14:43:07 EDT
(In reply to comment #14)
> Reopening.  Not yet fixed.

That doesn't help without more details/logs.
Comment 16 Orion Poplawski 2012-08-21 14:47:25 EDT
See attachment and comment 11 for TC3 failures.  When TC4 arrives (hopefully with patch from comment 12) I'll update.
Comment 17 Orion Poplawski 2012-09-05 12:41:27 EDT
Created attachment 610091 [details]
anaconda screenshot

Okay, with TC5 now it's choking on the cobbler use of:

%include /tmp/pre_install_network_config

in the main kickstart section.  I believe we ran into similar before.  Open a new bug, or keep on this one?
Comment 18 Adam Williamson 2012-09-21 19:09:37 EDT
orion: what's the status with Alpha final?
Comment 19 Orion Poplawski 2012-09-21 21:58:45 EDT
Exactly the same as TC5.  So I imagine it may work for many kickstarts, just not the one I use (from cobbler) that uses an include file in the main section that is generated in %pre.  Happy to file a new bug, or perhaps just change the title of this one?  We ran into this a well in an earlier release.  I could probably dig up the bug if it would be helpful.
Comment 20 Adam Williamson 2012-09-26 12:47:11 EDT
Discussed at 2012-09-26 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-09-26/f18-beta-blocker-review-1.2012-09-26-16.03.log.txt .

The relevant criterion here is "The installer must be able to successfully complete a scripted installation, using the installer's preferred scripting system, which duplicates the default interactive installation as closely as possible". The criterion about 'kickstart delivery methods' does not apply here, as *delivering* the kickstart certainly worked.

The relevant criterion is intentionally minimalistic: what it really means (per https://lists.fedoraproject.org/pipermail/test/2011-August/102368.html ) is 'if you do an all-defaults click-through interactive install of the Beta, then take the generated /root/anaconda-ks.cfg kickstart and feed it back into the installer, it should work'. That's the _only_ 'supported configuration', it's a strictly interpreted criterion, not an open one. This issue does not violate that criterion, on the information provided so far.

However, we don't reject this bug, as the idea with regard to kickstart criteria was that we'd have that criterion as a baseline and we could then look at individual cases to decide what more we wanted to support in terms of kickstart functionality. This is obviously an individual case we could evaluate and decide if we think whatever is broken is important enough to add it to the criteria, but first we need to know precisely what's broken, which at present we don't.

Therefore, we decided to delay the decision on this bug until we have a clearer understanding of what is broken.
Comment 21 Adam Williamson 2012-10-03 12:27:01 EDT
Discussed at 2012-10-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-03/f18-beta-blocker-review-2.2012-10-03-16.00.log.txt . The above note still stands, we did not yet get information on what's broken here. Tim Flink will try and reproduce the bug and poke anaconda team to look into it.
Comment 22 Orion Poplawski 2012-10-04 22:33:22 EDT
Bug 805316 was the one I was thinking of, but apparently that is somewhat different.  In any case this is still present in F18 Beta TC2.  I really hope this is fixed soon as I believe it's going to break a lot of cobbler driven installs.  My whole infrastructure is driven by cobbler, so I'm really not going to be able to do any real testing of F18 until this is fixed.
Comment 23 Adam Williamson 2012-10-05 04:45:44 EDT
that's certainly the kind of factor we can take into account in building out the requirements for kickstart functionality.
Comment 24 Adam Williamson 2012-10-10 12:33:59 EDT
Discussed at 2012-10-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-10/f18beta-blocker-review-3.2012-10-10-16.05.log.txt . Agreed we still are waiting for clear data on exactly what's broken here (though the info that it affects cobbler deployments helps). Tim didn't get around to looking into it last week, he will do so this week.
Comment 25 Kamil Páral 2012-10-15 10:57:24 EDT
Created attachment 627506 [details]
working kickstart with %include url

I tried to reproduce with the attached kickstart using F18 Beta TC4. The kickstart contains:

> %include http://kparal.fedorapeople.org/tmp/incl.ks

and the included file contained just:

> selinux --disabled

Everything worked. That means "%include <url>" is OK. That means either "%include <file>" is broken, or you need even more magic to break it.
Comment 26 Kamil Páral 2012-10-15 10:58:15 EDT
Orion, please include the kickstart file that breaks your installs, thank you.
Comment 27 Orion Poplawski 2012-10-15 12:40:18 EDT
Created attachment 627555 [details]
kickstart with %Include generated by %pre

Here's a simple example.  The file to be %included is generated by the %pre section.  This is a pretty standard cobbler generated kickstart file.

Ah, but I've found the problem now!  No more ifconfig!  So this is really a cobber issue.

if ifconfig -a | grep -i 00:16:3e:55:a7:2d
then
  IFNAME=$(ifconfig -a | grep -i '00:16:3e:55:a7:2d' | cut -d " " -f 1)
  if [ -z $IFNAME ]; then
    IFNAME=$(ifconfig -a | grep -i -B 2 '00:16:3e:55:a7:2d' | sed -n '/flags/s/:.*$//p')
  fi
  echo "network --device=$IFNAME --bootproto=dhcp" >> /tmp/pre_install_network_config
fi
+ grep -i 00:16:3e:55:a7:2d
+ ifconfig -a
/tmp/ks-script-bXE6OO: line 8: ifconfig: command not found
Comment 28 Adam Williamson 2012-10-15 19:39:11 EDT
CURRENTRELEASE isn't an appropriate resolution, changing to NOTABUG, as it really wasn't. Also dropping blocker status so we don't count this as some sort of fixed blocker in any kind of statistical analysis we do.
Comment 29 Orion Poplawski 2012-10-16 09:31:42 EDT
Well, the original problem was a bug :), but yes the second issue and current title of the bug was not.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.