Bug 847837 - No "java-devel" capability in java-1.7.0-openjdk-devel
No "java-devel" capability in java-1.7.0-openjdk-devel
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.7.0-openjdk (Show other bugs)
6.3
All Linux
medium Severity low
: rc
: ---
Assigned To: jiri vanek
BaseOS QE - Apps
:
Depends On:
Blocks: 835616 960054
  Show dependency treegraph
 
Reported: 2012-08-13 13:33 EDT by amturnip
Modified: 2015-07-23 03:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 13:05:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description amturnip 2012-08-13 13:33:05 EDT
Description of problem:

There is a packaging regression in java-1.7.0-openjdk-devel.

It does not provide the capability "java-devel = 1.7.0".

The "java-devel = 1.7.0" capability is provided by both
java-1.7.0-oracle-devel and java-1.7.0-ibm-devel.  It should be
provided by java-1.7.0-openjdk-devel also.  

The analogous "java-devel = 1.6.0" capability was provided by
java-1.6.0-openjdk-devel.

The absence of the "java-devel" capability in java-1.7.0-openjdk-devel
prevents yum from using an already-installed OpenJDK to satisfy a
capability-based BuildRequires statement like, "BuildRequires:
java-devel >= 1.7.0" when constructing RPM packages of Java programs.
Instead, yum will need to go get IBM Java or Oracle Java.

The "java-devel" capability is preferred over a specific package name,
e.g., java-1.7.0-openjdk-devel, in cases where all three devel
providers are equally suitable.  Someone who already has an Oracle or IBM
JDK installed should not need to install yet another very large
java-devel package in order to compile a Java program.

Note: The java-1.7.0-openjdk-devel package provides another
capability, java7-devel.  It is not a good substitute.  First and most
importantly, it will not match "BuildRequires: java-devel >= 1.6.0".
Second, and less importantly, the IBM and Oracle packages do not
provide it, so it is no better than a specific package name.

Exhibits:

OpenJDK 1.6.0:
$ rpm -q --provides -p java-1.6.0-openjdk-devel-1.6.0.0-1.48.1.11.3.el6_2.x86_64.rpm | grep -wE 'java.?-devel '
java-devel = 1:1.6.0

Oracle JDK 1.7.0:
$ rpm -q --provides -p java-1.7.0-oracle-devel-1.7.0.5-1jpp.1.el6.x86_64.rpm | grep -wE 'java.?-devel '
java-devel = 1:1.7.0

IBM JDK 1.7.0:
$ rpm -q --provides -p java-1.7.0-ibm-devel-1.7.0.1.0-1jpp.2.el6.x86_64.rpm | grep -wE 'java.?-devel '
java-devel = 1:1.7.0

OpenJDK 1.7.0 (bad):
$ rpm -q --provides -p java-1.7.0-openjdk-devel-1.7.0.5-2.2.1.el6_3.x86_64.rpm | grep -wE 'java.?-devel '
java7-devel = 1:1.7.0


Expected results:
$ rpm -q --provides -p java-1.7.0-openjdk-devel-1.7.0.5-2.2.1.el6_3.x86_64.rpm | grep -wE 'java.?-devel '
java-devel = 1:1.7.0
Comment 2 Deepak Bhole 2012-08-13 14:08:26 EDT
This was done intentionally (as was done in Fedora 16) to prevent Java 7 from accidentally being pulled in by yum during build/install (Oracle/IBM JDK are different because they are not in Base channel).

We should be able to do proper provider for 6.4 however. Acking for 6.4.
Comment 3 RHEL Product and Program Management 2012-09-07 01:34:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 jiri vanek 2013-05-21 13:05:55 EDT
The reply to this bug for rhel 6.X is  the https://bugzilla.redhat.com/show_bug.cgi?id=916288

Feel free to reopen if this need will rise again.

Note You need to log in before you can comment on or make changes to this bug.