Bug 847845 - ldap_autofs_* options missing from /usr/share/sssd/sssd.api.d/sssd-ldap.conf
ldap_autofs_* options missing from /usr/share/sssd/sssd.api.d/sssd-ldap.conf
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 14:11 EDT by Jason Tibbitts
Modified: 2013-04-10 07:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-10 07:00:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason Tibbitts 2012-08-13 14:11:25 EDT
I'm trying to write code with SSSDConfig to add several options to my sssd.conf:

ldap_autofs_map_object_class = nisMap
ldap_autofs_map_name = nisMapName
ldap_autofs_entry_object_class = nisObject
ldap_autofs_entry_key = cn
ldap_autofs_entry_value = nisMapEntry

Unfortunately the following code snippet fails:

#!/usr/bin/python
 
from SSSDConfig import SSSDConfig
a=SSSDConfig()
a.import_config('/tmp/sssd.conf')
a.activate_service('autofs')
b=a.get_domain('default')
b.add_provider('ldap', 'autofs')
b.set_option('ldap_autofs_map_object_class', 'nisMap')

with:
SSSDConfig.NoOptionError: Section [default] has no option [ldap_autofs_map_object_class]

It appears that /usr/share/sssd/sssd.api.d/sssd-ldap.conf has a section for "[provider/ldap/autofs]" but it contains no items at all.
Comment 1 Jakub Hrozek 2012-08-13 14:14:03 EDT
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1478
Comment 2 Jason Tibbitts 2012-08-13 14:15:55 EDT
I should note that I'm doing this in F17.
Comment 3 Jakub Hrozek 2012-09-07 13:17:36 EDT
Fixed in beta7 that hit rawhide yesterday is is going to be released f18 updates-testing soon.

Closing. Jason, thank you for reporting the bug. If you'd like to have this fix released for F-17, then holler and I'll build an updated package for you.
Comment 4 Jason Tibbitts 2012-09-07 13:33:33 EDT
I've long since rolled out an updated package with the upstream patch included.  I guess my only concern is whether any future F17 update would show up without that patch included, but I think I'd notice that pretty quickly and re-patch.
Comment 5 Jakub Hrozek 2012-09-07 13:41:18 EDT
I've made a local commit (not pushed) in the f17 branch of the SSSD fedora package -- that should prevent me from issuing an update without the patch :-)

I also plan to eventually backport SSSD 1.9 to F-17 when it bakes in F-18.
Comment 6 Jason Tibbitts 2012-10-25 15:31:42 EDT
Just a note that the 1.8.5 update that was pushed to F17 did not have this fix, so I had to re-patch.  Looking forward to 1.9.0 so I'll not have to worry about this again.
Comment 7 Fedora Update System 2012-10-26 07:22:27 EDT
sssd-1.8.5-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/sssd-1.8.5-3.fc17
Comment 8 Jakub Hrozek 2012-10-26 07:24:34 EDT
Sorry about that, I'm not sure where did the patch go..

I've built an F-17 update and put it through Bodhi.
Comment 9 Jason Tibbitts 2013-04-05 10:32:04 EDT
This appears to have come back at some point; the same code as in the initial comment fails in the same way with sssd-1.8.6-1.fc17.x86_64.  It's been a while since I installed a fresh F17 machine, but I'll dig up the patch and build a fixed package locally.
Comment 10 Jakub Hrozek 2013-04-05 10:38:17 EDT
(In reply to comment #9)
> This appears to have come back at some point; the same code as in the
> initial comment fails in the same way with sssd-1.8.6-1.fc17.x86_64.  It's
> been a while since I installed a fresh F17 machine, but I'll dig up the
> patch and build a fixed package locally.

Can you try if 1.9 from updates-testing works for you? If so, I would push that update to stable, it contains the fix.
Comment 11 Jason Tibbitts 2013-04-05 11:15:05 EDT
Yes, it does work fine.  I gave karma to the update.
Comment 12 Jakub Hrozek 2013-04-10 07:00:44 EDT
Fixed by an update.

Note You need to log in before you can comment on or make changes to this bug.