Bug 847860 - Registering a System using an Activation Key Fails
Registering a System using an Activation Key Fails
Status: CLOSED DUPLICATE of bug 848465
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Eric Helms
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 15:33 EDT by Eric Helms
Modified: 2013-08-16 13:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 12:41:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Helms 2012-08-13 15:33:20 EDT
Description of problem:
Attempting to register a system with an activation key fails due to the current user not being set properly.

Version-Release number of selected component (if applicable):
SE 1.0.1

How reproducible:
Always

Steps to Reproduce:
1. Create an Activation Key
2. Apply a subscription to the activation key
3. Using a client system properly configured, attempt to register using the activation key
  
Actual results:
Client system will receive an error: "Error updating system data, see /var/log/rhsm/rhsm.log for more details." 

And the /var/log/rhsm/rhsm.log will show: 
2012-08-13 14:40:19,793 [ERROR]  @cache.py:164 - Error updating system data
2012-08-13 14:40:19,793 [ERROR]  @cache.py:165 - Invalid credentials

Expected results:
The system should be registered appropriately or receive an error message that reflects the current state of the subscriptions attached to the Activation Key. 
For example, "Multi-entitlement not supported for pool with id"

Additional info:
This appears largely due to a chicken and egg problem whereby the current user is not properly set when attempting to look up activation keys when a client registers using an activation key.
Comment 4 Mike McCune 2012-08-15 12:41:43 EDT

*** This bug has been marked as a duplicate of bug 848465 ***
Comment 6 Mike McCune 2013-08-16 13:57:05 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.