Bug 84788 - rc.sysconfig console font loading bug
rc.sysconfig console font loading bug
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-21 08:20 EST by Péter, Soós
Modified: 2014-03-16 22:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-21 12:56:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Péter, Soós 2003-02-21 08:20:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030204

Description of problem:
rc.sysconfig init virtual consoles before loading console font. It causes the
system font loads the first virtual console only.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. configure system font via /etc/sysconfig/i18n
2. reboot you machine

    

Actual Results:  The configured font appears on the first virtual console only

Expected Results:  The configured font appears on _all_ virtual console only

Additional info:

Here is the fixed part of rc.sysconfig file:

 # Load system font
 if [ -x /sbin/setsysfont ]; then
    [ -f /etc/sysconfig/i18n ] && . /etc/sysconfig/i18n
    case "$LANG" in
      *.utf8*|*.UTF-8*)
        action $"Setting default font ($SYSFONT): " /bin/unicode_start $SYSFONT
        ;;
      *)
        action $"Setting default font ($SYSFONT): " /sbin/setsysfont
        ;;
    esac
    for i in 2 3 4 5 6; do
      > /dev/tty$i
    done
 fi
Comment 1 Miloslav Trmac 2003-02-21 12:35:13 EST
The font (and UTF-8 mode) is set again *after* you log in to the VT.
Every time you log out, console gets reset to the initial state.

That's not to say it is not a problem:
E.g. log out, press Ctrl-Alt-DEL. The initscripts messages output
when switching to runlevel 6 will be garbled if the locale
uses non-ASCII chars, because the console is not in UTF-8 mode
(I don't know whether the font is loaded). The right way to fix
this would really be making sure that the VTs are in the desired
mode *all the time*, not only when a user is logged on them.
I'm not sure how easily this can be done though.
Comment 2 Bill Nottingham 2003-02-21 12:56:58 EST
In response to the initial bug - no, you need to init the console *before* you
load the font for it to work right. This is a hack workaround; I'm fairly sure
this is a kernel bug that the font but not the mapping table are inherited on VC
creation.

Note You need to log in before you can comment on or make changes to this bug.