This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 847880 - tar-out should allow (or force) --numeric-owner
tar-out should allow (or force) --numeric-owner
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 17:54 EDT by Andy Lutomirski
Modified: 2012-08-14 12:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-14 12:56:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andy Lutomirski 2012-08-13 17:54:51 EDT
tar-out uses human-readable owners, which is unfortunate if the user of the resulting tarball has a different /etc/passwd than the guest.
Comment 1 Richard W.M. Jones 2012-08-13 17:59:36 EDT
Implementation notes:

Since commit 98757e151ae8ad8d334f028690abcc85b91c73e5
it has been possible to promote non-optargs functions (like
guestfs_tar_out) by adding optional arguments.  So (in
libguestfs >= 1.19.19) it should be easy to add optional
arguments to the guestfs_tar_out call, encoding this and
other flags.

Another one mentioned was --exclude= (bug 847881).  A single
exclude parameter could be modelled as an OString in the
generator, but that wouldn't be very useful since you could
only use it once.  It's probably better to add OStringList
and do this properly.
Comment 2 Richard W.M. Jones 2012-08-14 10:51:58 EDT
Patches posted:
https://www.redhat.com/archives/libguestfs/2012-August/msg00054.html
Comment 3 Richard W.M. Jones 2012-08-14 12:56:40 EDT
I pushed a less broken version of this patch upstream
in libguestfs 1.19.30.

Note You need to log in before you can comment on or make changes to this bug.