Bug 847900 - Tomcat 7.0.29 needs tomcat-native 1.1.4
Tomcat 7.0.29 needs tomcat-native 1.1.4
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tomcat-native (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 888934
  Show dependency treegraph
 
Reported: 2012-08-13 19:36 EDT by Andreas Girgensohn
Modified: 2013-01-22 20:35 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-14 16:33:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Girgensohn 2012-08-13 19:36:57 EDT
Description of problem:

After the update to Tomcat 7.0.29, the Apache Tomcat Native library is imcompatible.

Version-Release number of selected component (if applicable):

tomcat 7.0.29
tomcat-native 1.1.23

How reproducible:

Always

Steps to Reproduce:
1. Install tomcat-7.0.29 and tomcat-native-1.1.3.
2. Start the tomcat service
3. Check the log.
  
Actual results:

Log message:
SEVERE: An incompatible version 1.1.23 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.24

Expected results:

Tomcat and related packages should be updated such that they stay compatible with each other.

Additional info:
Comment 1 Ivan Afonichev 2012-08-15 04:38:48 EDT
It seems to be bug for tomcat-native package
Comment 2 Ivan Afonichev 2012-10-14 16:33:25 EDT
tomcat-native 1.1.24 update is now available for fedora 17.
Comment 3 Ivan Afonichev 2012-12-18 06:51:27 EST
Security issues with old tomcat were found so we updated tomcat on fedora 16.
It seems that now fedora 16 needs update of tomcat-native package too.
Comment 4 Ville Skyttä 2012-12-18 11:44:24 EST
(In reply to comment #3)
> Security issues with old tomcat were found so we updated tomcat on fedora 16.
> It seems that now fedora 16 needs update of tomcat-native package too.

1.1.24 build for F-16 is available in Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=373462

I no longer have a F-16 setup that I could test this for real with, so someone else who does can take care of submitting the update (maybe adding it to the tomcat update would work?) and pushing it forwards.
Comment 6 Fedora Update System 2012-12-19 17:01:57 EST
tomcat-native-1.1.24-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/tomcat-native-1.1.24-1.fc16
Comment 7 Fedora Update System 2013-01-22 20:35:09 EST
tomcat-native-1.1.24-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.