Bug 847916 - scl localstatedir includes prefix (.../usr/)
scl localstatedir includes prefix (.../usr/)
Status: CLOSED NEXTRELEASE
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: scl-utils (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: beta1
: 1.1
Assigned To: Jindrich Novy
Martin Cermak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 22:26 EDT by Frank Ch. Eigler
Modified: 2013-07-02 19:57 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-20 04:06:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2012-08-13 22:26:56 EDT
In the 3.6.5-0.3 builds, the various logs are put under /opt/rh/devtoolset-1.1/root/usr/var/log/pcp/*/*.log.  Note the extraneous /usr.
Comment 4 Nathan Scott 2012-08-14 19:57:19 EDT
Since pcp-3.6.6 will have the autoconf/prefix rework included, is this
bug worth investigating at this stage?  (given any 3.6.5 fix is certain
not to be applicable for 3.6.6, which is just around the corner).

Or is the -0.3 extension indicating a patched pcp-3.6.5, with --prefix
rework patched in?  Using http://brewweb.devel.redhat.com pointer from
late yesterday, I'm not finding the -0.3 build.
Comment 5 Frank Ch. Eigler 2012-08-17 23:23:08 EDT
According to /etc/rpm/macros.scl from scl-utils-build-20120423-2.el6:

%global _prefix %{_scl_root}/usr
%global _localstatedir %{_prefix}/var

_localstatedir should actually just be %{_scl_root}/var; compare /usr/lib/rpm/redhat/macros.  There might be other mismatches.
Comment 7 Jan Zeleny 2012-08-20 04:06:04 EDT
This is fixed in latest version of scl-utils that will be part of DTS 1.1. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.