Bug 847922 - kdump test: change device path to UUID
kdump test: change device path to UUID
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.5
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Caspar Zhang
Red Hat Kernel QE team
:
Depends On:
Blocks: 856039
  Show dependency treegraph
 
Reported: 2012-08-13 23:34 EDT by Caspar Zhang
Modified: 2013-07-03 03:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 13:21:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caspar Zhang 2012-08-13 23:34:31 EDT
Description of problem:

Currently several customers fail on kdump local test due to `vmcore not found` issue, however the vmcores did saved. After investigation, we have the following:

there are several disks attched, but the disk driver load sequence is different in first kernel and kdump kernel. So /dev/sda1 in first kernel might be /dev/sdb1 in second kernel. Then in kdump kernel, system tries to mount a incorrect partition, which is likely to cause error.

Thus, we need to use UUID or LABEL to avoid such loading sequence mismatch issue.

Version-Release number of selected component (if applicable):
1.5

How reproducible:

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 11 errata-xmlrpc 2013-02-01 13:21:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0222.html

Note You need to log in before you can comment on or make changes to this bug.