Bug 847944 - nfs_attr_use_mounted_on_file() returns wrong value [rhel-6.2.z]
Summary: nfs_attr_use_mounted_on_file() returns wrong value [rhel-6.2.z]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.4
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Frantisek Hrbata
QA Contact: Jian Li
URL:
Whiteboard:
Depends On: 842312
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-08-14 07:14 UTC by RHEL Product and Program Management
Modified: 2014-03-04 00:08 UTC (History)
10 users (show)

Fixed In Version: kernel-2.6.32-220.26.1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-11 17:34:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1254 normal SHIPPED_LIVE kernel bug fix and enhancement update 2012-09-11 21:32:27 UTC

Description RHEL Product and Program Management 2012-08-14 07:14:07 UTC
This bug has been copied from bug #842312 and has been proposed
to be backported to 6.2 z-stream (EUS).

Comment 7 Jian Li 2012-09-09 17:15:20 UTC
I try to test this bug as (https://bugzilla.redhat.com/show_bug.cgi?id=842312#c13), but, kenrel-2.6.32-220.26.1.el6 diff from 2.6.32.293, so I couldn't only reproducer it in pre-patch kernel. In post-patch kernel, server are not able to work with fault-inject newpynfs. 

Because, kernel wouldn't fetch fs_locations which make (fattr->valid & NFS_ATTR_FATTR_V4_REFERRAL==1) when nfs_fhget is called which call nfs_attr_use_mounted_on_fileid. in fact, nfs_attr_use_mounted_on_fileid always return 0, whatever fattr4_mounted_on_file is used. If fattr4_fileid is not, nfs client couldn't create the inode for server's file, just as test result showed.

 44     if (((fattr->valid & NFS_ATTR_FATTR_MOUNTED_ON_FILEID) == 0) ||
 45          ((fattr->valid & NFS_ATTR_FATTR_V4_REFERRAL) == 0))

Jeff, please check if I could verify this bug?

Comment 9 errata-xmlrpc 2012-09-11 17:34:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1254.html


Note You need to log in before you can comment on or make changes to this bug.