Bug 847983 - Mouse led off until right or left click right
Mouse led off until right or left click right
Status: CLOSED DUPLICATE of bug 825284
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 05:22 EDT by Cristian Gheorghe Florescu
Modified: 2013-03-14 15:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 15:27:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cristian Gheorghe Florescu 2012-08-14 05:22:06 EDT
Description of problem:
USB Mouse led off until right or left click pressed. This behavior occurs before and after login on Gnome 3 desktop

Version-Release number of selected component (if applicable):
FC17 i386 kernel 3.5.1 from updates repo
HP PRO 3400

How reproducible:
USB Mouse works fine and after 10 second without moving mouse it led goes off and mouse pointer remain still on the screen.


Steps to Reproduce:
1. Mouse work well
2. Wait 10-15 sec without moving mouse.
3. Led goes off
  
Actual results:
Desktop mouse pointer still

Expected results:
Desktop mouse pointer moving

Additional info:
I've changed 3 USB mice and was reached the same results
Using wireless mouse (Logitech) this error doesn't appear.
Comment 1 Josh Boyer 2012-08-14 08:55:55 EDT
This sounds like your mouse is set to auto-suspend.  What version of udev do you have installed and what does 

cat /sys/bus/usb/devices/<usb device of mouse>/power/control

say?

E.g.:

[jwboyer@zod kernel]$ dmesg | grep "Product: USB 3D Mouse"
[    3.040224] usb 1-1.1.3.2: Product: USB 3D Mouse
[jwboyer@zod kernel]$ cat /sys/bus/usb/devices/1-1.1.3.2/power/control 
on
[jwboyer@zod kernel]$ 

Getting that value while the LED is on and after it goes off would be good.
Comment 2 Cristian Gheorghe Florescu 2012-08-14 09:35:02 EDT
udev 182.1.fc17... current version... 

I've also tried udev from updates but with the same results.
I've tried 3 USB mice...

My issue is that screen point which remain still until click ... with my current kernel 3.3.4-5.fc17.i686 works well

P.S.
I've usually update only kernel from fedora updates.


Thank you for mouse info hint...
Comment 3 Josh Boyer 2012-08-14 10:07:26 EDT
(In reply to comment #2)
> udev 182.1.fc17... current version... 

That isn't current.  182-3.fc17 is current.

> I've also tried udev from updates but with the same results.
> I've tried 3 USB mice...

If you updated udev to 182-3.fc17 but haven't installed a new kernel since then, then all of your existing initramfses are booting with the older udev.

> My issue is that screen point which remain still until click ... with my
> current kernel 3.3.4-5.fc17.i686 works well

Yes, this sounds like bug 825284 which udev-182-3 fixes.
Comment 4 Cristian Gheorghe Florescu 2012-08-14 10:49:48 EDT
Thank you,

Seems to be solved accordingly with https://bugzilla.redhat.com/show_bug.cgi?id=825284...

My current installed udev is 182.1 but I've also updated to version 3 from updates repo and kernel 3.5.1 also from updates repo.

I didn't updated kernel from testing or rawhide.

I'll close this bug after upating from test repos.
Comment 5 Josh Boyer 2013-03-14 15:27:12 EDT

*** This bug has been marked as a duplicate of bug 825284 ***

Note You need to log in before you can comment on or make changes to this bug.