Bug 847995 - webadmin [Quota]: after commit of snapshot the vm disappears from the vm's sub tab under the quota's main tab
webadmin [Quota]: after commit of snapshot the vm disappears from the vm's su...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: ofri
vvyazmin@redhat.com
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 05:43 EDT by Dafna Ron
Modified: 2016-02-10 15:16 EST (History)
9 users (show)

See Also:
Fixed In Version: si17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:04:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log and screenshot (50.53 KB, application/x-gzip)
2012-08-14 05:43 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-08-14 05:43:48 EDT
Created attachment 604232 [details]
log and screenshot

Description of problem:

I committed a snapshot and the vm disappeared from the vm's sub tab under the quota main's tab. 

Version-Release number of selected component (if applicable):

si13.2

How reproducible:

100%

Steps to Reproduce:
1. create a  vm 
2. create several snapshot
3. preview -> commit the first snapshot (so we would have merge)
  
Actual results:

vm disappears from the vm's sub tab list under the quota main tab
we are however still seeing the quota use for the vm 

Expected results:

vm should not disappear. 

Additional info: screen shot and log
Comment 1 ofri 2012-08-26 07:37:59 EDT
Unable to reproduce on si15. please provide a reproducable. 
Please make sure that the commit is not done to a snapshot that points to a different quota. i.e. if snepshot S1 was taken when the VM was associated with quota Q1 and then the vm was reassociated to quota Q2 - the commit will associate the VM back to Q1.
Comment 2 Dafna Ron 2012-08-26 07:41:49 EDT
the vm was not moved to a different quota. 
but what you describe if happens is a bug as well.
Comment 3 ofri 2012-09-03 10:03:37 EDT
This was probably handled in a former patch (cant reproduce in current downstream). Please retest and reopen if needed.
Comment 4 vvyazmin@redhat.com 2012-09-09 07:04:39 EDT
Not reproduced on RHEVM 3.1 - SI17

RHEVM: rhevm-3.1.0-15.el6ev.noarch
VDSM: vdsm-4.9.6-32.0.el6_3.x86_64
LIBVIRT: libvirt-0.9.10-21.el6_3.4.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.295.el6_3.2.x86_64
SANLOCK: sanlock-2.3-3.el6_3.x86_64

Note You need to log in before you can comment on or make changes to this bug.