Bug 848003 - pkmon exit value is still unknown
pkmon exit value is still unknown
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: PackageKit (Show other bugs)
7.0
x86_64 Linux
unspecified Severity medium
: beta
: 7.0
Assigned To: Richard Hughes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 05:54 EDT by Vladimir Benes
Modified: 2012-11-01 06:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-01 06:15:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2012-08-14 05:54:10 EDT
Description of problem:
when running pkmon.. there should be exit code to each operation performed. But pkmon shows all the time exit code: unknown

Version-Release number of selected component (if applicable):
PackageKit-0.7.4-5.el7

How reproducible:
always

Steps to Reproduce:
1.start pkmon in one terminal
2.execute pkmon install mc

  
Actual results:
all transactions in pkmon have unknown exit code

Expected results:
all exit codes should be valid

Additional info:
Comment 1 Vladimir Benes 2012-08-23 08:08:08 EDT
this is caused by this:
14:02:50	PackageKit          internal error: failed, but no exit code: unknown
14:03:56	PackageKit          emit transaction-list-changed
14:03:56	PackageKit          last:	/1614_deebccdc_data
14:03:56	PackageKit          emit removed: /1614_deebccdc_data
14:03:56	PackageKit          removed: /1614_deebccdc_data
Comment 2 Richard Hughes 2012-11-01 06:15:07 EDT
This is fixed by:

commit c606d7a85076106a1d2be4d6ca8b49dbcd883702
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Oct 31 10:51:21 2012 +0000

    Do not abort the transaction if the plugin exits with success

:100644 100644 1331df6... 810c771... M  src/pk-transaction.c

Note You need to log in before you can comment on or make changes to this bug.