Bug 84801 - libxslt-1.0.26-1.src.rpm needs libxml2-devel >= 2.5.2 as prereq
libxslt-1.0.26-1.src.rpm needs libxml2-devel >= 2.5.2 as prereq
Product: Red Hat Raw Hide
Classification: Retired
Component: libxslt (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Veillard
Depends On:
  Show dependency treegraph
Reported: 2003-02-21 10:06 EST by Ken MacFarlane
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-02-21 11:08:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ken MacFarlane 2003-02-21 10:06:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030103

Description of problem:
rpmbuild --rebuild libxslt-1.0.26-1.src.rpm fails if libxml2-devel 2.5.1 is
installed.  Succeeded after installing 2.5.3.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install libxml2-devel-2.5.1 (e.g. from Phoebe)
2. rpmbuild --rebuild libxslt-1.0.26-1.src.rpm


Actual Results:  checking for libxml libraries >= 2.5.2... configure: error:
Version 2.5.1 found.
 You need at least libxml2 2.5.2 for this version of libxslt
error: Bad exit status from /var/tmp/rpm-tmp.51383 (%build)

Expected Results:  rpmbuild should have stated

    libxml2-devel >= 2.5.2 is needed for libxslt-1.0.26-1

and exited.

Additional info:
Comment 1 Daniel Veillard 2003-02-21 11:08:10 EST
Hum, right, I forgot to update the spec file with the new prereqs !
I updated the package with the correct dependancies,
This should hit RAWHIDE at the next update



Note You need to log in before you can comment on or make changes to this bug.