Bug 848019 - Kernel 3.5.x Fails To Boot / FC17 i686 with LVM
Kernel 3.5.x Fails To Boot / FC17 i686 with LVM
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
i686 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 06:39 EDT by Andy Morris
Modified: 2012-10-03 02:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 03:38:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Morris 2012-08-14 06:39:02 EDT
Hi all,

I'm looking for assistance on where to report technical errors to the people that maintain the kernel.

Our Sony Vaio (VPCW216AH) has been running happily with LVM+EXT4 encryption on FC17 (32 bit), up until when linux kernel 3.5.0-2 was released.

We are currently upto date with all software, and v3.5.1-1.fc17.i686 still contains whatever error is causing our problem.

I have set auto-update completely off so that nothing else gets updated as our GRUB still has v3.4.6-2.fc17.i686 which still works fine, and I don't want that to go off the list. (It seems that it keeps the latest 3 kernels in place).

Who can I pass the relevant information to, to get this issue resolved.
They'll need to tell me what they need to know so that I can note in down and post/email it.

Basically, after it boots on 3.5.x, I get dropped to a "Welcome to emergency mode" prompt that asks for the root password and then to a shell (root) prompt.

I can get no further than this point, other than to be returned back to emergency mode.

There's a whole page load of info on the screen, but I don't know what is relevant for an investigator to see, and what's not.

I have another, newer, Sony Vaio which is booting v3.5.1-1.fc17 (but 64-bit) without issues. That machine is my work-horse and would be dramatic if I hit the same issues with that machine.

Can anyone point me in the right direction to get this critical error assessed and fixed?

Thanks in advance.
Comment 1 Andy Morris 2012-08-21 05:39:12 EDT
6 days passed already guys (and gals)...

When we're living on your 'bleeding edge' with the latest Fedora, it would be nice to get some feedback from bug reports that come under the 'fail to boot' due to a kernel update.

Sorry to be a grind.
Comment 2 Andy Morris 2012-08-23 22:17:39 EDT
After 10 days of waiting for a response, I wiped Fedora from the machine.
I wont be able to provide any informatio relating to this error.

This bug can be closed due to "no response".
Comment 3 sbobber 2012-08-27 15:50:28 EDT
Hi, I've the same issue with a Vaio FC16/64bit LVM+EXT4 encryption + preupgrade -> FC17

after the upgrade to FC17 the only kernel that boot is the 3.4.9-1-fc16

with the 3.5.2-1.fc17 and the 3.5.2-3.fc17 I've the same problem of Mr.Morris: 

"Basically, after it boots on 3.5.x, I get dropped to a "Welcome to emergency mode" prompt that asks for the root password and then to a shell (root) prompt."

is possible to open the bug again? if is possible I'll prefer keep Fedora :)

TIA

S
Comment 4 Andy Morris 2012-08-27 20:20:37 EDT
Case re-opened for "sbobber". Good luck...
Comment 5 vitor.dominor 2012-09-18 21:31:13 EDT
Hello, all!
I'm no longer a Fedora Linux user, since I switched to Archlinux sometime ago.
When I recently updated to kernel 3.5.x, on my first boot afterwards, I noticed I was also dropped to the systemd emergency console. What is more, if I remove the kernel command line argument quiet, systemd outputs just before mounting partitions that it cannot find root and swap partitions, which in my case are lvm logical volumes.
This is also a problem with some archlinux users and like in fedora, archlinux maintainers are unable to find a solution. I guess it's something which has to be fixed upstream (kernel or lvm or device mapper, i don't know...). Anyway, we in archlinux at least found a sucessful workaround at explained in this thread: https://bbs.archlinux.org/viewtopic.php?id=145714&p=1.
Add the folowing kernel command line argument: lvmwait=<lvm logical volume containin your root partition>. It will cause systemd to wait for 10 seconds to find the root volume.
Comment 6 Andy Morris 2012-09-18 21:47:43 EDT
Thank you for sharing this information.
Comment 7 sbobber 2012-09-19 03:28:26 EDT
very interesting, I will try, thanks
Comment 8 sbobber 2012-10-02 03:23:29 EDT
not work for me... Andy, what you have choose after Fedora?
Comment 9 Andy Morris 2012-10-02 03:36:31 EDT
I went back to Ubuntu. Chosen for stability. I took Ubuntu 12.04.1 LTS 32-bit for the wifes machine, and removed LVM from the equation too, just in case I hit the same issue again (as that machine is 2yrs older than my own). That being said, I have a 12.04.1 LTS 64-bit with full LVM encryption too, and no issues with that yet, although Ubuntu is still only running kernel 3.2.0-31, which isn't the version where the issue of this Bug relates to. I would hope that later kernels avoid this issue. I will, at all costs, be sure to avoid kernel 3.5.x with any LVM configuration just in case. Good luck.
Comment 10 sbobber 2012-10-03 02:20:46 EDT
Thanks for the suggestion, IMHO similar issue should be considered with more care by fedora team

Note You need to log in before you can comment on or make changes to this bug.