Bug 848023 - ibus-anthy-setup SEGV by async IBus.Bus
ibus-anthy-setup SEGV by async IBus.Bus
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-anthy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:07dc48bc9aa900c5b5b0529a874...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 06:49 EDT by daniel.p.snowden
Modified: 2012-12-20 10:44 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:44:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description daniel.p.snowden 2012-08-14 06:49:55 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python /usr/share/ibus-anthy/setup/main.py
event_log:      2012-08-14-11:49:28> Smolt profile successfully saved
executable:     /usr/share/ibus-anthy/setup/main.py
kernel:         3.5.0-2.fc17.x86_64
time:           Tue 14 Aug 2012 11:47:46 AM BST
uid:            1000
username:       dan

backtrace:
:prefs.py:172:commit_item:AttributeError: 'NoneType' object has no attribute 'set_value'
:
:Traceback (most recent call last):
:  File "/usr/share/ibus-anthy/setup/main.py", line 818, in on_btn_apply_clicked
:    self.prefs.commit_all()
:  File "/usr/share/ibus-anthy/setup/prefs.py", line 146, in commit_all
:    self.commit_section(s)
:  File "/usr/share/ibus-anthy/setup/prefs.py", line 151, in commit_section
:    self.commit_item(section, k)
:  File "/usr/share/ibus-anthy/setup/prefs.py", line 172, in commit_item
:    self._config.set_value(s, key, variant)
:AttributeError: 'NoneType' object has no attribute 'set_value'
:
:Local variables in innermost frame:
:self: <anthyprefs.AnthyPrefs object at 0x147b810>
:variant: <GLib.Variant('Symbol')>
:s: 'engine/anthy/dict/file/ibus_symbol'
:key: 'long_label'
:v: 'Symbol'
:section: 'dict/file/ibus_symbol'

comment:
:error occured when changing settings for the "Anthy" Japanese language input tool.  Specifically, input mode was changed from "Romaji\2 to "Kana"
:
:Clicked OK and the error was indicated

smolt_data:
:
:
:General
:=================================
:UUID: 0e963c13-2add-4cb8-8350-0a3d14b77037
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 4589.97
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2301
:System Memory: 3851
:System Swap: 6143
:Vendor: Dell Inc.
:System: Latitude E5420 01
:Form factor: Laptop
:Kernel: 3.5.0-2.fc17.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7241:4136:1179) pci, None, PCI/ISA, HM65 Express Chipset Family LPC Controller
:(4631:5111:4136:1179) pci, firewire_ohci, FIREWIRE, N/A
:(32902:278:4136:1179) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7171:4136:1179) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7184:4136:1179) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:4136:1179) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7196:4136:1179) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 7
:(32902:7200:4136:1179) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(4631:33569:4136:1179) pci, sdhci-pci, BASE, N/A
:(32902:7188:4136:1179) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:7202:4136:1179) pci, None, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:130:32902:4897) pci, iwlwifi, NETWORK, Centrino Advanced-N 6205 AGN
:(4631:33076:4136:1179) pci, yenta_cardbus, PCI/CARDBUS, N/A
:(5348:5761:4136:1179) pci, tg3, ETHERNET, NetXtreme BCM5761 Gigabit Ethernet PCIe
:(32902:7213:4136:1179) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:4136:1179) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:4136:1179) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:4136:1179) pci, mei, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:7194:4136:1179) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 6
:(4631:33585:4136:1179) pci, None, STORAGE, N/A
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda7 / ext4 4096 4096 15709623 9333620 9176363 3932160 3717277 3717277
:/dev/sda6 WITHHELD vfat 16384 16384 6557501 3037031 3037031 0 0 0
:/dev/sdb1 WITHHELD fuseblk 4096 4096 244189695 167089607 167089607 668489500 668472817 668472817
:
Comment 1 fujiwara 2012-08-14 23:24:52 EDT
I cannot reproduce your problem.

(In reply to comment #0)
> :  File "/usr/share/ibus-anthy/setup/prefs.py", line 172, in commit_item
> :    self._config.set_value(s, key, variant)
> :AttributeError: 'NoneType' object has no attribute 'set_value'

I guess ibus-dconf is not running.
Are you still able to reproduce your problem?
Comment 2 Christopher Dare 2012-08-30 16:06:55 EDT
IBUS seems to be experiencing problems running on a new Fedora 17 base with UK English and Japanese ANTHY. Problem occurs during ibus-setup. System tray notifier also fails to respond at all times (left and/or right clicking).

Package: ibus-anthy-1.4.99.20120327-1.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 fujiwara 2012-09-11 04:53:08 EDT
OK, finally I could reproduced this problem.

Now GTK+ im-ibus.so uses ibus_bus_new_async() instead of ibus_bus_new() and then if ibus-setup-anthy calls GTK+ UI before ibus_bus_new(), the async function is called instead, and the delay is happened with the latest ibus 1.5.


The fix is to call ibus_bus_new() before GTK+.
And probably this is a good time to switch to the async functions for ibus-anthy 1.5
Comment 4 fujiwara 2012-09-11 04:54:48 EDT
#0  ibus_bus_new_async () at ibusbus.c:647
#1  0x00007fffe7fc37e8 in ?? ()
   from /usr/lib64/gtk-3.0/3.0.0/immodules/im-ibus.so
...
#87 0x00007fffef6dacf1 in gtk_builder_add_from_file (builder=0xc90f70,
    filename=0xc7a3a0 "/usr/share/ibus-anthy/setup/setup.ui", error=
    0x7fffffffce70) at gtkbuilder.c:897
...
#92 0x00007ffff0cafc41 in ?? ()
   from /usr/lib64/python2.7/site-packages/gi/_gi.so
Comment 6 Mike FABIAN 2012-09-25 11:12:44 EDT
I stumbled into this problem on Fedora-18-Alpha-RC3.1.
Comment 7 fujiwara 2012-09-26 05:32:15 EDT
I will update ibus-anthy in this week.
Comment 8 Jonathan Burgess 2012-10-05 14:38:45 EDT
Clicking Apply or OK after configuring Anthy.

Package: ibus-anthy-1.4.99.20120327-1.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 9 Fedora Update System 2012-10-06 10:16:17 EDT
ibus-anthy-1.4.99.20121006-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-anthy-1.4.99.20121006-1.fc18
Comment 10 Fedora Update System 2012-10-06 10:16:51 EDT
ibus-anthy-1.4.99.20121006-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-anthy-1.4.99.20121006-1.fc17
Comment 11 Fedora Update System 2012-10-06 14:41:39 EDT
Package ibus-anthy-1.4.99.20121006-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-anthy-1.4.99.20121006-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15532/ibus-anthy-1.4.99.20121006-1.fc18
then log in and leave karma (feedback).
Comment 12 Jens Petersen 2012-10-15 09:46:37 EDT
Thanks looks fixed with the update to me.
Comment 13 Fedora Update System 2012-12-20 10:44:24 EST
ibus-anthy-1.4.99.20121006-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.