Bug 848029 - convertion of book fails
convertion of book fails
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: calibre (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 07:18 EDT by Sebastian Dyroff
Modified: 2012-10-06 13:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-06 13:30:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error output from the calibre conversion dialog (21.98 KB, text/plain)
2012-08-14 07:18 EDT, Sebastian Dyroff
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 892492 None None None 2012-08-15 18:30:17 EDT

  None (edit)
Description Sebastian Dyroff 2012-08-14 07:18:43 EDT
Created attachment 604266 [details]
Error output from the calibre conversion dialog

Description of problem:

trying to convert the Fedora System Administrator's Guide from epub to mobi fails. Error log is attached.

Version-Release number of selected component (if applicable): 0.8.50


How reproducible: always

Steps to Reproduce:
1. right click on the System Administrator's Guide ebook, select convert books -> convert individually
2. hit ok.
Comment 1 Kevin Fenzi 2012-08-14 17:05:36 EDT
It seems like it did produce the converted file ok? 

Can you check with the version in updates-testing? 
https://admin.fedoraproject.org/updates/FEDORA-2012-11860/calibre-0.8.63-1.fc17
Comment 2 Sebastian Dyroff 2012-08-14 18:06:52 EDT
In the temporary directory are only 2 files left:

./CtJfdb_worker_redirect.log
./ipc_result_1_1_1B7x0C.pickle

also no mobi file in the calibre library.

I moved my ~/.config/calibre folder away, just in case it is a configuration error. This did not yield to the desired result.

I will try the testing version tomorrow.
Comment 3 Sebastian Dyroff 2012-08-14 18:49:29 EDT
I tried the testing version calibre-0.8.63-1.fc17. It lead to the same error.

I also tried it in a freshly installed kvm vm, still the same error.
Comment 4 Kevin Fenzi 2012-08-15 14:02:55 EDT
Strange, it says: 

MOBI output written to /tmp/calibre_0.8.50_tmp_DgOkKK/ven_R2.mobi

but perhaps it removed it as incomplete. 

Would you be willing to file this upstream? 
https://bugs.launchpad.net/calibre
Comment 5 Sebastian Dyroff 2012-08-15 18:30:17 EDT
This bug was already filed upstream. 

https://bugs.launchpad.net/calibre/+bug/892492

Happens only with xfce < 4.10. Workaround is deleting ~/.ICEauthority before converting the book.
Comment 6 Kevin Fenzi 2012-08-15 18:36:15 EDT
Ah ha. Very good detective work. 

I wonder if it's worth asking Xfwm4 upstream about fixing it, or if we should simply live with it until 4.10 is rolled out in all Fedora releases. ;(
Comment 7 Sebastian Dyroff 2012-08-15 19:00:30 EDT
For me waiting is fine. I doubt someone is willing to hunt this bug down. Seems as if there are many components involved (xserver, xfce4-session).
Comment 8 Kevin Fenzi 2012-08-15 19:22:03 EDT
Well, xfce 4.10 is already available in my side repo: 

http://repos.fedorapeople.org/repos/kevin/xfce-4.10/

for fedora-16 and fedora-17. 

Fedora 18 will ship with 4.10.
Comment 9 Kevin Fenzi 2012-10-06 13:30:22 EDT
I guess there's nothing much for us to do here...

Note You need to log in before you can comment on or make changes to this bug.