This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 848033 - init script return wrong value for configtest
init script return wrong value for configtest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind (Show other bugs)
6.3
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomáš Hozza
qe-baseos-daemons
: Patch
Depends On:
Blocks: 1070830
  Show dependency treegraph
 
Reported: 2012-08-14 07:33 EDT by albert
Modified: 2014-10-14 00:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: bind-9.8.2-0.26.rc1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Initscript returned a wrong return value if called checkconfig/configtest/check/test due to a missing statement in the initscript. Consequence: As a result, when named configuration included an error and 'service named configtest' was called, it exited with zero value (meaning success) regardless of errors in the configuration. Fix: Initscript was fixed to return the correct value when executed with checkconfig/configtest/check/test. Result: As a consequence, when named configuration includes an error and 'service named configtest' is called, it exits with non-zero value (meaning failure).
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 00:34:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Set RETVAL to checkconfig return value (623 bytes, patch)
2013-04-05 07:21 EDT, Tomáš Hozza
no flags Details | Diff

  None (edit)
Description albert 2012-08-14 07:33:02 EDT
Description of problem:

service named configtest always returns 0

Version-Release number of selected component (if applicable):

bind-9.8.2-0.10.rc1.el6_3.2.x86_64

How reproducible:

Always

Steps to Reproduce:
1.put a typo in /etc/named.conf or in a zone
2.
3.
  
Actual results:

service named configtest returns 0 (OK)

Expected results:

service named configtest should return 1

Additional info:

I think there's a missing RETVAL=$? after the call to checkconfig() internal function
Comment 2 Adam Tkac 2012-09-05 08:09:17 EDT
(In reply to comment #0)
> I think there's a missing RETVAL=$? after the call to checkconfig() internal
> function

Right you are, thanks for the report.
Comment 4 Tomáš Hozza 2013-04-05 07:21:08 EDT
Created attachment 731887 [details]
Set RETVAL to checkconfig return value
Comment 6 RHEL Product and Program Management 2013-10-13 20:31:37 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 12 errata-xmlrpc 2014-10-14 00:34:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1373.html

Note You need to log in before you can comment on or make changes to this bug.