Bug 848118 - Please update Install doc to state that SAM can be run on physical or virtual machines.
Please update Install doc to state that SAM can be run on physical or virtual...
Status: CLOSED CURRENTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: Docs Installation Guide (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: sachua
ecs-bugs
:
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-08-14 12:32 EDT by Bryan Kearney
Modified: 2014-06-18 03:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-11 19:48:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Kearney 2012-08-14 12:32:41 EDT
From a comment on the customer portal:
<SNIP>

Page 5 of the Red Hat document I have entitled "Red_Hat_Subscription_Asset_Manager-1.1-Installation_Guide-en-US" clearly states that the self-hosted SAM system must be a physical server. 

</SNIP>

Please update this text to denote it can be physical or virtual.
Comment 3 Toby Fruth 2013-02-18 11:26:20 EST
I assume SAM will work fine on a VM, but I need to know if it's supported.

Again, from version 1.1 of the SAM Guide:

Chapter 2. Installation

2.1. Installing from the Repository
2.2. Installing in a Virtual Environment

Installation of Subscription Asset Manager is done on a physical networked host. Subscription Asset Manager is included with a Red Hat subscription at no additional cost. You need to have a valid Red Hat Network (RHN) subscription, and be registered to RHSM to begin your installation of Subscription Asset Manager. You can use Subscription Asset Manager to manage subscriptions on both physical systems and virtual machines. 


Is there a newer guide version with updated content? This "bug" is six months old.
Comment 4 Bryan Kearney 2013-02-18 11:30:05 EST
SAM on a VM should be supported. Since content is proxied through this VM, there may be IO issues inherent to a VM. The latest docs for SAM 1.1 should be in the customer portal.
Comment 5 Toby Fruth 2013-02-18 12:11:00 EST
Thanks for the update.

Above I quoted text from SAM 1.1 doc https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Subscription_Asset_Manager/1.1/html/Installation_Guide/chap-Installation_Guide-Installation.html 

SAM 1.0 doc lacks the physical requirement text, and the SAM 1.2 Beta doc says:

Chapter 2. Installation

2.1. Installing from the Repository
2.2. Installing from ISO

Installation of Subscription Asset Manager can be done on a physical or virtual networked host.

Note You need to log in before you can comment on or make changes to this bug.