Bug 848122 - RFE - new version of piklab is available, supporting new devices and it is ported to KDE4
Summary: RFE - new version of piklab is available, supporting new devices and it is po...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: piklab
Version: 17
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Alain Portal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-08-14 16:51 UTC by Branko Grubić
Modified: 2012-09-25 16:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-25 16:36:43 UTC
Type: Bug


Attachments (Terms of Use)
>0.15.2 ChangeLog (737 bytes, text/plain)
2012-08-14 16:51 UTC, Branko Grubić
no flags Details
updated piklab.spec (11.15 KB, text/x-rpm-spec)
2012-08-16 09:58 UTC, Branko Grubić
no flags Details
re-written .desktop-fr.patch (637 bytes, patch)
2012-08-16 09:59 UTC, Branko Grubić
no flags Details | Diff
added patch fix-compilation-with-kde4 (557 bytes, patch)
2012-08-16 10:00 UTC, Branko Grubić
no flags Details | Diff
added patch fix-kate-part-path (510 bytes, patch)
2012-08-16 10:01 UTC, Branko Grubić
no flags Details | Diff
new piklab.spec (11.17 KB, text/x-rpm-spec)
2012-08-16 21:36 UTC, Branko Grubić
no flags Details
updated piklab.spec fixed deps (11.20 KB, text/x-rpm-spec)
2012-08-16 22:11 UTC, Branko Grubić
no flags Details

Description Branko Grubić 2012-08-14 16:51:35 UTC
Created attachment 604368 [details]
>0.15.2 ChangeLog

There is a recent release of piklab which features support for new devices and it's it is ported to KDE4 now. 

Source: http://piklab.sourceforge.net/changelog.php 
New version: 0.16.1
We have: 0.15.12 in f17

I would like to have it in f17 if it is possible, if not, would be nice to have it in f18.

Comment 1 Branko Grubić 2012-08-16 09:58:28 UTC
Created attachment 604868 [details]
updated piklab.spec

Comment 2 Branko Grubić 2012-08-16 09:59:35 UTC
Created attachment 604869 [details]
re-written .desktop-fr.patch

Comment 3 Branko Grubić 2012-08-16 10:00:41 UTC
Created attachment 604871 [details]
added patch fix-compilation-with-kde4

Comment 4 Branko Grubić 2012-08-16 10:01:30 UTC
Created attachment 604872 [details]
added patch fix-kate-part-path

Comment 5 Branko Grubić 2012-08-16 10:02:08 UTC
I tried to update the spec file and build a new package, there was a issue with a build system for the package, which is now fixed upstream.

This is done with a lot of help from people at #fedora-kde especially <Kevin_Kofler> and <rdieter>

From original spec I removed patches: 
piklab-0.12.1.x-desktop-fr.patch  (file x-piklab.desktop doesn't exist in the source, nothing to patch?) 
piklab-0.15.12-cmake-readline.patch  (file which _needs_ to be patched changed a lot from last release we have in fedora)
piklab-0.15.12-gcc47.patch fixed upstream 
piklab-0.15.12-sdcc-3.0.0.patch fixed upstream

Patches added or re-wrtitten:
piklab-0.16.1-fix-compilation-with-kde4-r2952.patch  added fixes missing include files (fixed upstream, but I was not able to use upstream patch because of other changes to the file in the trunk version)
piklab-0.16.1-fix-kate-part-path-r2936.patch added, fixes kate-part files path, fixed upstream
piklab-0.16.1.desktop-fr.patch re-written

I will attach new piklab.spec, and two new patches and one which is re-written. 


This is my first spec file changed, so it is probably not perfect, but it builds a packge without errors (using rpmbuild) ... 

I did something which is probably wrong, but it's easy to fix, I changed all patch file names to match new version of piklab.

Comment 6 Branko Grubić 2012-08-16 21:36:05 UTC
Created attachment 605029 [details]
new piklab.spec

I think this new .spec file fixes the following rpmlint error 
piklab.x86_64: E: script-without-shebang /usr/share/mime/packages/piklab.xml

the line which fixes it: 
%attr(644, -, -)%{_datadir}/mime/packages/*

Comment 7 Branko Grubić 2012-08-16 22:11:39 UTC
Created attachment 605035 [details]
updated piklab.spec fixed deps

New .spec fixes two required runtime dependencies (program worked without them, at least some basic tasks, opening project, programming device, ...)
but by running it from terminal there was two errors 

piklab(15470)/kdeui (KIconLoader): Error: standard icon theme "oxygen" not found! 

adds oxygen-icon-theme as runtime dependency 

piklab(15470): Couldn't start kuiserver from kuiserver.desktop:  "Could not find service 'kuiserver.desktop'."

adds kde-runtime as runtime dependency

Now, no specific errors during runtime

Comment 8 Fedora Update System 2012-09-20 13:55:27 UTC
piklab-0.16.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/piklab-0.16.1-2.fc17

Comment 9 Fedora Update System 2012-09-20 13:55:42 UTC
piklab-0.16.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/piklab-0.16.1-2.fc16

Comment 10 Fedora Update System 2012-09-20 13:55:57 UTC
piklab-0.16.1-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/piklab-0.16.1-2.el6

Comment 11 Fedora Update System 2012-09-20 13:56:08 UTC
piklab-0.16.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/piklab-0.16.1-2.fc18

Comment 12 Fedora Update System 2012-09-21 20:52:06 UTC
Package piklab-0.16.1-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing piklab-0.16.1-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-12939/piklab-0.16.1-2.el6
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2012-09-25 16:36:43 UTC
piklab-0.16.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.