Bug 848124 - RFE - IP address of the remote host accessed via squid in version 3.2
RFE - IP address of the remote host accessed via squid in version 3.2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: squid34 (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Luboš Uhliarik
Martin Frodl
Milan Navratil
: FutureFeature
Depends On:
Blocks: 1172231 1303068
  Show dependency treegraph
 
Reported: 2012-08-14 13:15 EDT by Jesse Triplett
Modified: 2016-05-10 20:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
*Squid* can log IP addresses and ports of remote hosts In previous versions, the *Squid* caching and forwarding web proxy had the ability to log the URL, which included the host name. However, *Squid* could not log the IP address of the destination server. This update enables *Squid* to log IP addresses and ports of remote hosts, which is especially useful when dealing with hosts that have multiple IP addresses.
Story Points: ---
Clone Of:
: 1303068 (view as bug list)
Environment:
Last Closed: 2016-05-10 20:12:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Triplett 2012-08-14 13:15:05 EDT
1. Proposed title of this feature request
IP address of the remote host accessed via squid in version 3.2


2. Who is the customer behind the request?
Account name: Colorcon
Customer segment:Tudor Panaitescu
TAM/SRM customer: no
Strategic Customer: no


3. What is the nature and description of the request?
We are trying to find ways to correlate squid log information and firewall (Cisco ASA) log info inside a SIEM but we came across a problem related to web sites with multiple ip addresses (i.e google, when you do a nslookup on www.google.com you get multiple IP addresses). Squid 3.1 logs the URL, which includes the hostname but doesn't have the capability to log the IP address of the destination while ASA loggs just the IP address. Squid 3.2 has that capability (check squid config logformat documentation for <a and <p) and I was wondering if you guys can backport that feature into the mainline RHEL6.X so we have that correlation point.

4. Why does the customer need this? (List the business requirements here)
implement SIEM (Security Information and Event Management) + event correlation w/ info from squid; <IP Address>:<port> of the destination host would be correlated w/ firewall logging info and also w/ IDS info

5. How would the customer like to achieve this? (List the functional requirements here)
by using <A and log_ip_on_direct, but I still believe that it would be helpful to have the port as well, <p option in squid 3.2.

6. For each functional requirement listed in question 5, specify how Red Hat
and the customer can test to confirm the requirement is successfully
implemented.


7. Is there already an existing RFE upstream or in Red Hat bugzilla?
No

8. Does the customer have any specific timeline dependencies?
No

9. Is the sales team involved in this request and do they have any additional input?
No

10. List any affected packages or components.
squid-3.1.x.el6

11. Would the customer be able to assist in testing this functionality if implemented?
Comment 2 Tom Lavigne 2012-09-07 11:25:31 EDT
This request was evaluated by Red Hat Product Management for 
inclusion in the current release of Red Hat Enterprise Linux.
Since we are unable to provide this feature at this time,  
it has been proposed for the next release of 
Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2013-10-13 20:31:31 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 16 errata-xmlrpc 2016-05-10 20:12:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0882.html

Note You need to log in before you can comment on or make changes to this bug.