Bug 848131 - logrotate uses inverse umask
logrotate uses inverse umask
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: logrotate (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Kaluža
Tomas Dolezal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 13:47 EDT by Daniel Crisman
Modified: 2014-01-30 04:21 EST (History)
3 users (show)

See Also:
Fixed In Version: logrotate-3.7.8-17.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 05:35:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (382 bytes, patch)
2012-08-14 13:47 EDT, Daniel Crisman
no flags Details | Diff

  None (edit)
Description Daniel Crisman 2012-08-14 13:47:03 EDT
Created attachment 604377 [details]
patch

The patch for bug 680798 which "fixes the issue by creating temp file with umask 0000" wants to limit access to the temp file so that should be a umask of 0777.

Use of mkstemp with recent versions of glibc covers up this error a bit as the file is created "with permissions 0600".

Version-Release number of selected component (if applicable):
From logrotate-3.7.8-15.el6.src.rpm
Comment 2 RHEL Product and Program Management 2012-09-07 01:11:59 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 8 errata-xmlrpc 2013-07-18 05:35:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1095.html

Note You need to log in before you can comment on or make changes to this bug.