Bug 848133 - The OK button in the "New Host" dialog box doesn't work if you click cancel from the "Power Management" dialog box.
The OK button in the "New Host" dialog box doesn't work if you click cancel f...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Alexey Chub
Lukas Svaty
infra
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 13:50 EDT by Bill Sanford
Modified: 2016-02-10 14:42 EST (History)
13 users (show)

See Also:
Fixed In Version: SI19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"Enable Power Management" checkbox (39.82 KB, image/jpeg)
2012-08-19 09:13 EDT, Alexey Chub
no flags Details

  None (edit)
Description Bill Sanford 2012-08-14 13:50:20 EDT
Description of problem:

Add a host in the WebAdmin Portal. In the "New Host" dialog box, type in the name and the IP address of the host you want to add and click OK. When the "Power Management Configuration" dialog box pops up, click cancel. This will being you back to the "New Host" dialog box and the left tab is on "Power Management." Click the "General" tab and enter the password you forgot to put it and click OK. The OK button will never work since the dialog box thinks it still has focus on the "Power Management" tab as you see with a yellow outline on the tab. The only way to correct this is to click the cancel button and start over.

Version-Release number of selected component (if applicable):
RHEV-M si14

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:
OK button fails to work.

Expected results:
OK button works.

Additional info:
Comment 2 Alexey Chub 2012-08-19 09:13:07 EDT
Button does work. There is an indication that something wrong on "Power Management" tab (it's highlighted with orange border). And you see which fields are mandatory (they are highlighted too). And it's because checkbox "Enable Power Management" being enabled.

The question here, if we need to enable the checkbox, or just switch to the "Power Management" tab after a confirmation dialog closed?
IMHO no - this behavior is not understood to user, as a result we have a bug opened.
Comment 3 Alexey Chub 2012-08-19 09:13:52 EDT
Created attachment 605488 [details]
"Enable Power Management" checkbox
Comment 4 Bill Sanford 2012-08-20 08:30:07 EDT
How come I can enter the host parameters and not enter the "Power Management" options and enter OK and it works? If I go back to enter the password, then it recognizes that the "Power Management" is empty? This is a regression.
Comment 5 Bill Sanford 2012-08-22 08:44:43 EDT
Hitting cancel should not enable the "Enable Power Management" checkbox to be selected.
Comment 6 Barak 2012-08-30 11:14:26 EDT
Miki - as this issue is in your domain and you probably were involved in the current behaviour, please advise.
Comment 7 Miki Kenneth 2012-08-30 11:29:00 EDT
alexey,

1. The yellow rectangle is need clear enough, can we add a message. Eldan advise as well.
2. regarding c#5 - bill is right, when we hit cancel and all the fields are empty, (at least when coming from the pop up) should not set the enable PM...

ELDAN?
Comment 8 Alexey Chub 2012-09-02 07:18:50 EDT
Change-Id: I7636e84ffc66ae6fda3d3bc5f5c48d9e1449da6a

Note You need to log in before you can comment on or make changes to this bug.