Bug 848148 - Error in PREIN scriptlet in rpm package wireshark-1.6.9-1.fc17.x86_64
Summary: Error in PREIN scriptlet in rpm package wireshark-1.6.9-1.fc17.x86_64
Keywords:
Status: CLOSED DUPLICATE of bug 844167
Alias: None
Product: Fedora
Classification: Fedora
Component: wireshark
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Safranek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-08-14 18:31 UTC by Charles R. Anderson
Modified: 2012-08-15 02:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-15 02:40:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Charles R. Anderson 2012-08-14 18:31:24 UTC
Description of problem:

Installing wireshark via yum, there is an error in the %pre script.

Version-Release number of selected component (if applicable):
wireshark-1.6.9-1.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. yum install wireshark-gnome

  
Actual results:

# yum install wireshark-gnome
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package wireshark-gnome.x86_64 0:1.6.9-1.fc17 will be installed
--> Processing Dependency: wireshark = 1.6.9-1.fc17 for package: wireshark-gnome-1.6.9-1.fc17.x86_64
--> Processing Dependency: libwsutil.so.1()(64bit) for package: wireshark-gnome-1.6.9-1.fc17.x86_64
--> Processing Dependency: libwiretap.so.1()(64bit) for package: wireshark-gnome-1.6.9-1.fc17.x86_64
--> Processing Dependency: libwireshark.so.1()(64bit) for package: wireshark-gnome-1.6.9-1.fc17.x86_64
--> Running transaction check
---> Package wireshark.x86_64 0:1.6.9-1.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package              Arch        Version            Repository            Size
================================================================================
Installing:
 wireshark-gnome      x86_64      1.6.9-1.fc17       updates-testing      815 k
Installing for dependencies:
 wireshark            x86_64      1.6.9-1.fc17       updates-testing       10 M

Transaction Summary
================================================================================
Install  1 Package (+1 Dependent package)

Total download size: 11 M
Installed size: 61 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): wireshark-1.6.9-1.fc17.x86_64.rpm                 |  10 MB     00:01     
(2/2): wireshark-gnome-1.6.9-1.fc17.x86_64.rpm           | 815 kB     00:00     
--------------------------------------------------------------------------------
Total                                           5.8 MB/s |  11 MB     00:01     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Error in PREIN scriptlet in rpm package wireshark-1.6.9-1.fc17.x86_64
error: %pre(wireshark-1.6.9-1.fc17.x86_64) scriptlet failed, exit status 10
  Installing : wireshark-gnome-1.6.9-1.fc17.x86_64                          2/2 
error: wireshark-1.6.9-1.fc17.x86_64: install failed
  Verifying  : wireshark-gnome-1.6.9-1.fc17.x86_64                          1/2 
  Verifying  : wireshark-1.6.9-1.fc17.x86_64                                2/2 

Installed:
  wireshark-gnome.x86_64 0:1.6.9-1.fc17                                         

Failed:
  wireshark.x86_64 0:1.6.9-1.fc17                                               

Complete!
# rpm -qa wireshark\*
wireshark-gnome-1.6.9-1.fc17.x86_64
# package-cleanup --problems
Loaded plugins: refresh-packagekit
Package wireshark-gnome-1.6.9-1.fc17.x86_64 has missing requires of libwireshark.so.1()(64bit)
Package wireshark-gnome-1.6.9-1.fc17.x86_64 has missing requires of libwiretap.so.1()(64bit)
Package wireshark-gnome-1.6.9-1.fc17.x86_64 has missing requires of libwsutil.so.1()(64bit)
Package wireshark-gnome-1.6.9-1.fc17.x86_64 has missing requires of wireshark = ('0', '1.6.9', '1.fc17')

# rpm -qp --scripts wireshark-1.6.9-1.fc17.x86_64.rpm 
preinstall scriptlet (using /bin/sh):
getent group wireshark >/dev/null || groupadd -r wireshark

#



Expected results:

%pre script should not fail.

wireshark should have been installed as well as wireshark-gnome.


Additional info:

Comment 1 Charles R. Anderson 2012-08-14 18:33:47 UTC
Not sure why it fails in the package, it works from command line:

# getent group wireshark || echo no
no

# getent group wireshark >/dev/null || groupadd -r wireshark

# grep wireshark /etc/group
wireshark:x:989:

# getent group wireshark
wireshark:x:989:

Comment 2 Charles R. Anderson 2012-08-15 02:40:02 UTC

*** This bug has been marked as a duplicate of bug 844167 ***


Note You need to log in before you can comment on or make changes to this bug.