Bug 848155 - package net-snmp-5.5-41.el6_3.1.x86_64 always fail to read these three values of UCD-DISKIO-MIB, diskIOLA1, diskIOLA5, diskIOLA15
Summary: package net-snmp-5.5-41.el6_3.1.x86_64 always fail to read these three values...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: net-snmp
Version: 6.3
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Jan Safranek
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-08-14 18:51 UTC by Christoph Galuschka
Modified: 2018-11-30 20:02 UTC (History)
2 users (show)

Fixed In Version: net-snmp-5.5-44.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, values of UCD-DISKIO-MIB::diskIOLA1, diskIOLA5 and diskIOLA15 objects were not implemented on Linux operating system. With this update, these objects are implemented and their values will be shown in UCD-DISKIO-MIB::diskIOTable.
Clone Of:
Environment:
Last Closed: 2013-02-21 10:27:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0421 normal SHIPPED_LIVE net-snmp bug fix and enhancement update 2013-02-20 20:49:35 UTC

Description Christoph Galuschka 2012-08-14 18:51:28 UTC
Description of problem:
Here is the output of snmptable, notice it display all question marks under the diskIOLA1/diskIOLA5/diskIOLA15 column:

# snmptable -v 2c -c public 127.0.0.1 diskIOTable

SNMP table: UCD-DISKIO-MIB::diskIOTable

 diskIOIndex diskIODevice diskIONRead diskIONWritten diskIOReads diskIOWrites diskIOLA1 diskIOLA5 diskIOLA15 diskIONReadX diskIONWrittenX
           1 ram0 0 0 0 0 ? ? ? 0 0
           2 ram1 0 0 0 0 ? ? ? 0 0
           3 ram2 0 0 0 0 ? ? ? 0 0
           4 ram3 0 0 0 0 ? ? ? 0 0
           5 ram4 0 0 0 0 ? ? ? 0 0
           6 ram5 0 0 0 0 ? ? ? 0 0
           7 ram6 0 0 0 0 ? ? ? 0 0
           8 ram7 0 0 0 0 ? ? ? 0 0
           9 ram8 0 0 0 0 ? ? ? 0 0
          10 ram9 0 0 0 0 ? ? ? 0 0
          11 ram10 0 0 0 0 ? ? ? 0 0
          12 ram11 0 0 0 0 ? ? ? 0 0
          13 ram12 0 0 0 0 ? ? ? 0 0
          14 ram13 0 0 0 0 ? ? ? 0 0
          15 ram14 0 0 0 0 ? ? ? 0 0
          16 ram15 0 0 0 0 ? ? ? 0 0
          17 loop0 0 0 0 0 ? ? ? 0 0
          18 loop1 0 0 0 0 ? ? ? 0 0
          19 loop2 0 0 0 0 ? ? ? 0 0
          20 loop3 0 0 0 0 ? ? ? 0 0
          21 loop4 0 0 0 0 ? ? ? 0 0
          22 loop5 0 0 0 0 ? ? ? 0 0
          23 loop6 0 0 0 0 ? ? ? 0 0
          24 loop7 0 0 0 0 ? ? ? 0 0
          25 sr0 0 0 0 0 ? ? ? 0 0
          26 sda 2210736128 263530496 3414176 195768919 ? ? ? 15095638016 1318818490368
          27 sda1 2273280 18432 604 10 ? ? ? 2273280 18432
          28 sda2 2207827968 263512064 3413417 195768909 ? ? ? 15092729856 1318818471936
          29 dm-0 2195543040 170389504 3447900 321954431 ? ? ? 15080444928 1318725349376
          30 dm-1 11272192 93110272 2752 22732 ? ? ? 11272192 93110272
          31 dm-2 570368 12288 140 3 ? ? ? 570368 12288

Version-Release number of selected component (if applicable):
net-snmp-libs-5.5-41.el6_3.1.x86_64
net-snmp-utils-5.5-41.el6_3.1.x86_64
net-snmp-5.5-41.el6_3.1.x86_64

How reproducible:
always

Steps to Reproduce:
1. Install net-snmp incl. dependencies
2. start snmpd and query "snmptable -v 2c -c public 127.0.0.1 diskIOTable"
  
Actual results:
diskIOLA1 diskIOLA5 diskIOLA15 only shows ?

Expected results:
diskIOLA1 diskIOLA5 diskIOLA15 should show a number

Additional info:

Comment 2 Jan Safranek 2012-08-29 13:13:58 UTC
This has already been fixed upstream in SVN rev. 19233.

Comment 3 Christoph Galuschka 2012-08-29 18:25:27 UTC
Jan, thanks for the information.
Will the fix make it to the snmp-package used in RHEL6?

Comment 4 RHEL Product and Program Management 2012-09-10 08:39:33 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 6 Christoph Galuschka 2012-09-14 14:58:46 UTC
So there will be a fix for this in an upcoming update?

Comment 11 errata-xmlrpc 2013-02-21 10:27:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0421.html


Note You need to log in before you can comment on or make changes to this bug.