Bug 84818 - wrong be-latin1 keyboard mapping
wrong be-latin1 keyboard mapping
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-21 12:11 EST by Gregory Petit
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version: 1.12-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-26 20:46:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Petit 2003-02-21 12:11:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
I've downloaded phoebe-3 and when I choose the keyboard layout
belgian(be-latin1), I have 2 wrong key mappings.

I don't know if this is a bug for redhat-config-keyboard, because, when I edit
/lib/kbd/keymaps/i386/azerty/be-latin1.map.gz, it says:

keycode  86 = less             greater          backslash

1)This is the good keyboard mapping, but when I type "alt-gr + <" (it should
give a backslash) it gives a bar.
2)The key next to 'zero' on the numeric keypad should be a period, and is mapped
as a comma.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Choose keyboard layout belgian(latin-1)

    

Actual Results:  1)Type "ALT-GR + <" and it gives a bar

2)Press the key next to zero on the num.pad, it gives a comma

Expected Results:  1) bar should be backslash

2)comma should be period

Additional info:

Red Hat Linux release 8.0.94 (Phoebe)
redhat-config-keyboard-1.0.3-4
Comment 1 Brent Fox 2003-02-26 12:47:09 EST
Transferring to kbd.
Comment 2 Eido Inoue 2004-02-26 20:46:22 EST
Simulated with my current keyboard-- key near the bottom left should
be "<>\" key.

AltGr with that key produces the correct character with kbd 1.12-1

Note You need to log in before you can comment on or make changes to this bug.