Bug 8482 - cookie left on screen when "ZZ" exiting "TERM=xterm vi"
cookie left on screen when "ZZ" exiting "TERM=xterm vi"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
6.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-14 19:18 EST by Ronald Cole
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-30 09:49:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Cole 2000-01-14 19:18:59 EST
[ronald@yakisoba ronald]$ TERM=xterm vi
c[ronald@yakisoba ronald]$
^ this is the undesirable cookie

[ronald@yakisoba ronald]$ TERM=vt100 vi
[ronald@yakisoba ronald]$
^ no cookie, as I would expect

This is probably a terminfo bug, but there is no "terminfo" component
to select.

This doesn't happen on RH6.0.  Really annoying to look at.  My productivity
has been lower since...  ;)
Comment 1 Bernhard Rosenkraenzer 2000-01-18 05:10:59 EST
Doesn't happen to me on a current 6.2 snapshot...
Which terminal are you using? xterm, konsole, gnome-terminal, rxvt, ..... ?
Comment 2 Ronald Cole 2000-01-18 15:16:59 EST
gnome-terminal
Comment 3 Bill Nottingham 2000-02-05 15:38:59 EST
Only happens with /bin/vi, not vim.
Comment 4 khp 2000-03-03 20:13:59 EST
This happens to me with /usr/bin/vim on three 6.1 systems:
VIM - Vi IMproved 5.4 (1999 Jul 25, compiled Jul 27 1999 18:08:35)
but not with gvim. Note that the annoying "c" character is put out upon entering
vim, not when exiting. I'm using gnome-terminal.
Comment 5 Luca Bonomi 2000-03-30 09:49:59 EST
This happens to me since 6.1 and also in 6.2 using 'konsole'.
Not seen if I use kvt or xterm.
Comment 6 Bernhard Rosenkraenzer 2000-08-08 08:23:18 EDT
fixed
Comment 7 Daniel Roesen 2000-12-21 19:27:19 EST
Fixed in rawhide vims? I heard that newest gnome-terminal doesn't exhibit this
problem. Is it a vim bug or gnome-terminal problem?
Comment 8 Ronald Cole 2000-12-21 19:33:39 EST
I don't know.  *Something* was broken in 6.1 and 6.2.  It seems fixed in 7.0.  I
don't know about rawhide.
Comment 9 Daniel Roesen 2000-12-21 21:11:36 EST
Rawhide vim rebuilt from SRPM on 6.2 works. No more bogus "c" on stdout.
Comment 10 Pete Zaitcev 2000-12-23 22:53:58 EST
Here is the problem as I see it. In term.c, vim uses
KS_CRV to request version, with escape sequence "\033[>c".
This is taken from xterm docs, but is wrong. Actual sequence
has no '>', to which both xterm and gnome-terminal reply.
However, if one would remove '>', he/she triggers another
bug in vim: version reply is not eaten properly and it gets
input as a vim command.

The best fix is to comment out the KS_CRV entry in term.c.

Did anyone communicate this to vim folks?

Note You need to log in before you can comment on or make changes to this bug.