Bug 848205 - brasero ignoring File/Image Checksum type
brasero ignoring File/Image Checksum type
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: brasero (Show other bugs)
7.0
x86_64 Linux
unspecified Severity medium
: rc
: 7.1
Assigned To: David King
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 17:31 EDT by Mark Gordon
Modified: 2015-09-08 16:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 16:16:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (4.39 KB, patch)
2012-12-17 12:57 EST, Tomáš Bžatek
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 719995 None None None Never

  None (edit)
Description Mark Gordon 2012-08-14 17:31:02 EDT
Description of problem:
If I set the File Checksum or Image Checksum plugins in brasero to use something other than md5 (SHA1 and SHA256 are nominally supported), I see no evidence of anything other than md5 being used for anything.

Version-Release number of selected component (if applicable):
brasero-3.4.1-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Launch brasero
2. Edit -> Plugins
3. File Checksum, Configure -> Select SHA1
4. Image Checksum, Configure -> Select SHA1
5. Create a data project, and add any regular file to it.
6. Burn an image of the project.
7. Mount the resultant ISO.
  
Actual results:
1. A file /tmp/brasero_tmp_[six random characters].md5 is generated
2. The ISO has a .checksum.md5 file with the md5sum of the file that was included in the data project

Expected results:
I'd expect SHA1 to be used instead of md5.

Additional info:
SHA256 doesn't work, either.

It's possible I'm missing something here, and it's intentionally hardcoded to use md5 for these things and uses SHA1 somewhere else that I'm unaware of, in which case this bug should be closed, but from here, it looks like this setting is ignored.
Comment 2 Tomáš Bžatek 2012-12-17 12:57:22 EST
Created attachment 665016 [details]
proposed patch

Silly patch that fixes the issue, but I don't like it.
Comment 7 Jiri Koten 2015-05-13 08:43:19 EDT
Still reproducible in brasero-3.12.0-1.el7.
Comment 8 Matthias Clasen 2015-09-08 16:16:24 EDT
IT seems unlikely that we will get a fix for this unless it appears upstream.

Note You need to log in before you can comment on or make changes to this bug.