Bug 848207 - [jboss-as-5] Create Child XA, Local Tx, and No Tx Datasource resource should provide templates for many common datasource types as described in jboss-as/docs/examples/jca
[jboss-as-5] Create Child XA, Local Tx, and No Tx Datasource resource should ...
Status: CLOSED UPSTREAM
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 5 (Show other bugs)
JON 3.1.0
All All
medium Severity low
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On: 880860
Blocks: 1088652
  Show dependency treegraph
 
Reported: 2012-08-14 17:51 EDT by Larry O'Leary
Modified: 2014-06-12 19:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 880860 (view as bug list)
Environment:
Last Closed: 2014-06-12 19:57:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 185813 None None None 2012-08-14 19:27:27 EDT

  None (edit)
Description Larry O'Leary 2012-08-14 17:51:46 EDT
Description of problem:
When creating a new datasource child resource for an as-5 server a list of templates is presented. However, the list only provided Oracle as a template. It would be ideal that other templates be provided.

Perhaps one possibility is to simply separate the template definitions from the plug-in descriptor and plug-in JAR and point the plug-in at a local directory to find template information? This type of feature would allow the user to add other templates based on their own datasource descriptor requirements and ensure that the plug-in JAR itself would not need to be modified or revised to include new templates or changes to existing templates.

Version-Release number of selected component (if applicable):
JON 3.1.0 - RHQ 4.4.0

How reproducible:
Always

Steps to Reproduce:
1.  Start EAP server
2.  Start JON server and agent
3.  Import EAP server into inventory
4.  Navigate to imported EAP resource
5.  Select the EAP resource's Inventory > Child Resources tab
6.  Select Create Child -> XA Datasource

Actual results:
Notice *Resource Configuration Template* only contains `default` and `Oracle XA`.

This can also be seen when selecting Local Tx Datasource and No Tx Datasource.  


Expected results:
Other templates should be available in the *Resource Configuration Template* drop-down.
Comment 2 Larry O'Leary 2014-06-12 19:57:20 EDT
Due to the changes in how datasource configuration is managed and maintained in later release of JBoss EAP, this bug is being closed as upstream bug 880860.

If someone wants to add the additional templates to the as5 plug-in upstream, we can look into getting them into JBoss ON.

Note You need to log in before you can comment on or make changes to this bug.