Bug 848217 - Creating, connecting to or configuring OpenVPN connections seems entirely broken in F18
Creating, connecting to or configuring OpenVPN connections seems entirely bro...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager-openvpn (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 18:42 EDT by Adam Williamson
Modified: 2014-02-05 07:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 07:03:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-08-14 18:42:40 EDT
OpenVPN connections seem completely broken in current F18, with:

NetworkManager-0.9.5.96-2.fc18.x86_64
NetworkManager-openvpn-0.9.3.997-3.fc18.x86_64
openvpn-2.2.2-6.fc18.x86_64

If I try to connect to an existing (and working, in F17) OpenVPN connection with the GNOME shell menu thingy, I just get a 'Activation of network connection failed' notification. If I go to the GNOME control center 'Network' thingy and click the 'on/off' toggle for the connection, same thing. If I try to configure the connection, I get a dialog 'Error initializing editor: Insufficient privileges'. If I try to create a new OpenVPN connection, I get the normal VPN connection editing dialog, but everything is greyed out and inaccessible except the 'Cancel' button.

nm-connection-editor appears to behave correctly for editing the connection, but doesn't have an option to activate it. If I try and do it with nmcli:

[adamw@adam sources]$ nmcli con up uuid 9725a88c-ff5c-400e-9c1c-3dccfee33038
Error: Connection activation failed: no valid VPN secrets.

This VPN uses two-factor auth so I have to enter the password each time I connect to it, but in neither case of attempting to enable the connection am I actually prompted for the password. The failure is returned immediately. Password is set to Always Ask, according to nm-connection-editor, so it _should_ be asking (and this was working fine in F17 before I upgraded).
Comment 1 Adam Williamson 2012-09-28 14:39:54 EDT
Still broken with:

NetworkManager-0.9.7.0-1.git20120820.fc18.x86_64
NetworkManager-openvpn-0.9.3.997-3.fc18.x86_64
openvpn-2.2.2-9.fc18.x86_64

I see this in /var/log/messages when trying to open the VPN connection:

Sep 28 11:38:42 adam NetworkManager[734]: <error> [1348857522.661199] [nm-vpn-connection.c:1405] get_secrets_cb(): Failed to request VPN secrets #2: (6) No agents were available for this request.
Comment 2 Dan Williams 2012-09-28 14:48:27 EDT
The "Failed to request VPN secrets: no agents" means that neither GNOME Shell's network applet, or nm-applet, were running, or that  neither of them had any secrets to provide.  Check ~/.xsession-errors for stuff that looks like NM.

In reality, I think we probably just need an NM-openvpn update.

One more thing to try:

systemctl stop NetworkManager
NetworkManager -no-daemon --log-level=debug --log-domains=core,device,hw,vpn,agents

which will spew a lot, but has info about what agents actually register with NM to provide secrets.
Comment 3 Adam Williamson 2012-09-28 14:48:46 EDT
further notes: nothing seems to show up in xsession-errors for any kind of attempt to init the connection. 'nmcli con list' as user shows no connections; as root it shows all connections. 'nmcli con up uuid 9725a88c-ff5c-400e-9c1c-3dccfee33038' as user says that's an unknown connection, as root triggers the 'no valid VPN secrets' error. right now, trying to bring up the connection via the Shell menu doesn't show the 'no valid VPN secrets' error, it simply fails completely silently.
Comment 4 Adam Williamson 2012-09-28 14:50:05 EDT
Back in .xsession-errors I do have one line from nm-applet:

(nm-applet:1655): Gdk-WARNING **: nm-applet: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

what would the process name for 'GNOME Shell's network applet' be?
Comment 5 Dan Williams 2012-09-28 15:22:12 EDT
Anyone who's running into this give:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4538595

a shot and let me know if it works.  Restarting GNOME Shell (Alt + F2, then r and Return) after installing the update is a good idea as well, just to rule out the shell being weird.  No restarted required, BTW.
Comment 6 Adam Williamson 2012-09-28 16:22:58 EDT
With GNOME 3.6.0 and that NM-openvpn build, things start working OK for me.
Comment 7 Adam Williamson 2012-10-01 00:10:38 EDT
Well, that one time it worked, but actually seems not fully fixed. I just tried connecting again, I've probably rebooted in between, and got:

Sep 30 21:07:00 adam NetworkManager[739]: <error> [1349064420.678140] [nm-vpn-connection.c:1405] get_secrets_cb(): Failed to request VPN secrets #2: (6) No agents were available for this request.

in /var/log/messages , again. No error message. I then tried restarting NetworkManager.service to see if that would help, it just makes things worse...the GNOME panel network icon now shows the 'disconnected' x (though actually the connection is up and running, and the GNOME control center Network applet reports this) and the OpenVPN connection is not present in the panel menu or the applet at all.
Comment 8 Jamie Duncan 2013-04-16 01:21:17 EDT
I'm running into this now, out of the blue. Is there any movement on it? The koji build in C#5 has been deleted.
Comment 9 John Dennis 2013-05-30 21:37:12 EDT
FWIW I also just got hit by this on F18 (x86-64), also seemingly out of the blue. Any suggestions?
Comment 10 Adam Williamson 2013-05-30 21:39:59 EDT
it's been fine for me in f18 and f19 lately, fwiw.
Comment 11 John Dennis 2013-05-30 22:06:19 EDT
I think my problem was actually the one in bug #888068. I had restarted NetworkManager and vpnc does not handle that well. After rebooting the problem went away.
Comment 12 Fedora End Of Life 2013-12-21 03:40:49 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 13 Fedora End Of Life 2014-02-05 07:03:25 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.