Bug 848229 - After setting up a calendar evolution draws tree incorrectly
After setting up a calendar evolution draws tree incorrectly
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 20:02 EDT by Ben Woodard
Modified: 2013-07-31 23:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 23:46:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of the missing text in the tree. (21.03 KB, image/png)
2012-08-14 20:02 EDT, Ben Woodard
no flags Details
redering mismatch (250.11 KB, image/png)
2012-08-14 20:36 EDT, Ben Woodard
no flags Details
screenshot of rendering problem (35.34 KB, image/png)
2012-09-18 18:39 EDT, Ben Woodard
no flags Details

  None (edit)
Description Ben Woodard 2012-08-14 20:02:13 EDT
Created attachment 604480 [details]
screen shot of the missing text in the tree.

Description of problem:
After setting up a calendar evolution draws the tree of accounts incorrectly

Version-Release number of selected component (if applicable):
evolution-3.4.3-2.fc17.x86_64

How reproducible:
Has happened a couple of times.

Steps to Reproduce:
1. setup a new calendar
2. note how the drawing turns the text for the calendar white or something like that see attached picture.
  
Actual results:
text missing or white

Expected results:
normal text or black text

Additional info:
This also happened in contacts when I setup ldap contacts for zimbra. The problem seemed to persist after I restarted evolution but then later when I looked again after another restart of evolution the text was fine.
Comment 1 Ben Woodard 2012-08-14 20:36:59 EDT
Created attachment 604484 [details]
redering mismatch

restarting evolution didn't fix the problem. However, when I opened up a new window it did render properly in the new window. Surprisingly, the original window when clicked from the mail to calendars still renders improperly. This screen shot shows the windows side by side.
Comment 2 Milan Crha 2012-08-15 04:57:47 EDT
Thanks for a bug report. I tried to reproduce, but it works fine for me with evolution-3.4.3 and gtk3-3.4.3-2. Is anything shown on console when you run evolution from it and reproduce the issue? Could you also try with evolution 3.4.4, which was released this Monday and is currently in updates-testing, please?
Comment 3 Ben Woodard 2012-09-18 18:38:17 EDT
I just saw the phenomena earlier today when I setup gmail's contact address book. This was with:

evolution-3.4.4-1.fc17.x86_64
gtk3-3.4.4-1.fc17.x86_64
Comment 4 Ben Woodard 2012-09-18 18:39:13 EDT
Created attachment 614143 [details]
screenshot of rendering problem

Here is a picture of the phenomena
Comment 5 Milan Crha 2012-10-15 09:03:29 EDT
Strange. Is anything on the console, when you run evolution from it, please?
Comment 6 Volker Sobek 2012-10-15 12:37:41 EDT
Same issue here, in the terminal I see:

(evolution:3518): e-data-server-ui-CRITICAL **: pixbuf_cell_data_func: assertion `G_IS_OBJECT (data)' failed
Comment 7 Milan Crha 2012-10-15 12:55:10 EDT
As we spoke with Volker on IRC a bit, I suggested to try to reproduce with valgrind, because the runtime warning seems to be about an object being freed too early, making me think of a reference counting error, possibly discovered or introduced by some memory leak fix(es). The only issue is with a good reproducer.

Please make sure you have installed debuginfo packages at least for evolution-data-server and evolution, before involving valgrind with command like this:
   $ G_SLICE=always-malloc valgrind --num-callers=50 evolution &>log.txt
Note the evolution will be significantly slower, due to all memory checking.
Comment 8 Volker Sobek 2012-10-15 13:27:41 EDT
So I currently have state where every time I start evolution this bug occurs. But when I run evolution with gdb or valgrind, the bug does not show up. The next time I start evolution alone the bug is there again.

I also downgraded the following 3 packages to:

evolution-3.4.1-2.fc17.x86_64
evolution-data-server-3.4.1-2.fc17.x86_64
evolution-NetworkManager-3.4.1-2.fc17.x86_64

but the bug still occurs with these.
Comment 9 Fedora End Of Life 2013-07-03 20:15:22 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 10 Fedora End Of Life 2013-07-31 23:46:10 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.