Bug 848298 - Unable to undo a preview of a snapshot with no snappable disks
Unable to undo a preview of a snapshot with no snappable disks
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
All All
unspecified Severity unspecified
: ---
: 3.1.0
Assigned To: Allon Mureinik
Leonid Natapov
storage
:
: 847759 (view as bug list)
Depends On: 854185
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 04:15 EDT by Allon Mureinik
Modified: 2016-02-10 12:54 EST (History)
10 users (show)

See Also:
Fixed In Version: si16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:07:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
VDSM log (115.97 KB, text/plain)
2012-08-15 04:16 EDT, Allon Mureinik
no flags Details
oVirt Engine log (22.37 KB, text/plain)
2012-08-15 04:17 EDT, Allon Mureinik
no flags Details

  None (edit)
Description Allon Mureinik 2012-08-15 04:15:37 EDT
Description of problem:
When trying to undo a preview of a snapshot of a VM with no snappable disks an error message ("Cannot revert to Snapshot. VM's Snapshot does not exist.") is displayed instead of undoing the snapshot

Version-Release number of selected component (if applicable):
Commit hash 53d618f3b302c296709431b0d29716a96982504e

How reproducible:
100%

Steps to Reproduce:
1. Create a VM with no disks
2. Take a snapshot
3. Preview to that snapshot
4. Undo the preview
  
Actual results:
An error message is displayed: "Cannot revert to Snapshot. VM's Snapshot does not exist."

Expected results:
Preview should be undone.

Additional info:
Comment 1 Allon Mureinik 2012-08-15 04:16:24 EDT
Created attachment 604544 [details]
VDSM log
Comment 2 Allon Mureinik 2012-08-15 04:17:20 EDT
Created attachment 604545 [details]
oVirt Engine log
Comment 3 Allon Mureinik 2012-08-15 08:17:13 EDT
Patch pushed to gerrit, pending review:
http://gerrit.ovirt.org/#/c/6676/
Comment 4 Dafna Ron 2012-08-15 10:41:27 EDT
*** Bug 847759 has been marked as a duplicate of this bug. ***
Comment 5 Allon Mureinik 2012-08-28 07:59:45 EDT
merged Change-Id: Ic62eee3cfb03abd21905ad6aa132c8cc10dbfb70
Comment 6 Leonid Natapov 2012-09-06 10:34:47 EDT
si17. fixed.

Note You need to log in before you can comment on or make changes to this bug.