Bug 84830 - Installer hangs when loading aic7xxx module on a 440GX board
Summary: Installer hangs when loading aic7xxx module on a 440GX board
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-21 20:06 UTC by Forrest
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-13 18:48:00 UTC


Attachments (Terms of Use)
dmidecode output (15.24 KB, text/plain)
2003-02-21 21:28 UTC, Forrest
no flags Details
dmi_scan patch including the newest BIOS (3.28 KB, patch)
2003-02-24 18:51 UTC, Forrest
no flags Details | Diff

Description Forrest 2003-02-21 20:06:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030120

Description of problem:
The Phoebe beta 3 installer hangs when loading the aic7xxx module for an onboard
Adaptec SCSI chipset on a L440GX motherboard.  The installer worked on previous
betas and on 8.0.  I'll try the apic trick for the installation, and see if that
bypasses the problem.

How reproducible:
Always

Steps to Reproduce:
1.  Boot from phoebe beta 3 on a 440GX motherboard

Actual Results:  When loading the aic7xxx module, the scsi bus goes into an
infinite loop.

Comment 1 Arjan van de Ven 2003-02-21 20:40:29 UTC
there is no more apic option as per release notes.
please send dmidecode output of your machine so that we can add it to the 440gx list

Comment 2 Forrest 2003-02-21 21:28:49 UTC
Created attachment 90261 [details]
dmidecode output

Here is the dmidecode output from the machine

Comment 3 Forrest 2003-02-21 21:31:24 UTC
I was attempting to install via NFS, so I tried the boot.iso image first.  This
resulted in the infinite loop.

Next I tried the bootdisk.img + drvnet.img floppies.  This resulted in a total
machine hang after ~3 seconds of trying to load the aic7xxx module.

Comment 4 Arjan van de Ven 2003-02-21 21:39:55 UTC
yes if you machine isn't in the bios version list of the 440gx blacklist you'll
have no chance of booting at all.

I've added your bios to the list so the next build will boot.

Unfortionatly our support for the 440GX platform is minimal and best-effort only
due to lack of programming information required to make these machines work.

Comment 5 Forrest 2003-02-21 22:51:31 UTC
What changes do I need to make to get this installed--is it something in the
kernel or in anaconda?

Comment 6 Arjan van de Ven 2003-02-21 23:02:54 UTC
you need a rebuilt kernel
see the arch/i386/kernel/dmi_scan.c file
it has a whole list of 440GX bioses, but not yours yet.
Add an entry for yours and it'll work :)


Comment 7 Forrest 2003-02-24 18:13:15 UTC
The BIOS release notes for the 440GX boards detailed here: 
ftp://aiedownload.intel.com/df-support/3306/ENG/Relnotes.txt
specify all of the BIOS numbers possible.  An example of the latest BIOS (which
I happen to have):

BLD    Date             L440GX+
133    3/26/01          L440GX+ Production Release 14.3
			Based on BUILD 132
			1.  Banner Roll to Production Release 14.3.
			2.  Updated microcode update for CPUID 683h B-0
				stepping processors to revision 13.

The DMI BIOS number is L440GX0.86B.0133.P14, showing the the build and
production number.  Thus we can deduce the rest of the BIOS versions from the
list, which should cover all of the BIOSes for the board.  I can gather that
information and post it here if you would like.


Comment 8 Forrest 2003-02-24 18:51:19 UTC
Created attachment 90316 [details]
dmi_scan patch including the newest BIOS

Comment 9 Michael K. Johnson 2003-02-26 17:25:49 UTC
Giving Alan the opportunity to consider these for -ac...

Comment 10 Forrest 2003-05-13 18:48:00 UTC
Great job getting the BIOSes in Red Hat Linux 9!  I was able to install it on my
440GX board where Phoebe 3 would not.


Note You need to log in before you can comment on or make changes to this bug.