Bug 848321 - samba fails to delete files when "delete_on_close" is set due to inode mismatch
samba fails to delete files when "delete_on_close" is set due to inode mismatch
Status: CLOSED WORKSFORME
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Christopher R. Hertel
Ujjwala
:
Depends On: 832622
Blocks: 858443
  Show dependency treegraph
 
Reported: 2012-08-15 05:22 EDT by Vidya Sakar
Modified: 2014-09-28 20:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 832622
: 858443 (view as bug list)
Environment:
Last Closed: 2012-12-05 22:01:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-15 05:22:47 EDT
+++ This bug was initially created as a clone of Bug #832622 +++

Description of problem:
End user complained that since upgrading to 3.3.0 every time they edit a MS Office file it leaves behind a temp file.

How reproducible:
Every time

Steps to Reproduce:
1. Re-share a glusterfs fuse mount with samba
2. Put an excel spreadsheet on that share
3. Open that excel spreadsheet in MS Excel
4. Make a small edit
5. Close the file, saving changes
 
Actual results:
The ${FILENAME}~${SOME_RANDOM_BITS}.TMP will remain behind.

Expected results:
That TMP file is opened via samba with a flag set to delete on close. Samba declines to delete the file because it detects that the inode has changed.

Additional info:
A loglevel=15 log from samba shows the error where samba detects that the inode has changed. The change is that the 64 bit inode has been truncated to 32 bits. Mounting by running glusterfs from the command line and setting --attribute-timeout=0 works around this problem.
Comment 2 Amar Tumballi 2012-09-04 05:13:12 EDT
need to check the behavior on RHS. (considering there is a work around available). and also 32bit inode numbers are involved here. May not be applicable to RHS version.

Would be great if QE team helps here by confirming the behavior on RHS nodes.
Comment 3 Ujjwala 2012-09-05 03:06:59 EDT
I tested it with the following setup:
RHS 2.0.z update2 - 4 node cluster, Dis-rep volume
windows 7 64-bit client
MS Office 2007

Steps Followed:
1. Fuse mount the gluster volume
2. Put a MS excel file created on MS office 2007 on the mount point
3. Map the share on windows 7 64-bit machine
4. Open the MS excel file.
5. edit it, save it and close it.
6. Create a new excel file on the win 7 client, put some data and save it.
7. Opened the above 2 files from a 2nd win 7 client and edited it

Results:
Did not see and .tmp file creation in the above steps mentioned.
Also checked the users temp folder.

Can we get info on which MS office version, this behavior was seen.
Comment 4 Amar Tumballi 2012-12-05 22:01:58 EST
closing as per comment #3

Note You need to log in before you can comment on or make changes to this bug.