Bug 848362 - [SetupNetworks] BOND created when using network with name eth0
[SetupNetworks] BOND created when using network with name eth0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Alona Kaplan
Meni Yakove
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 07:53 EDT by Meni Yakove
Modified: 2016-02-10 14:54 EST (History)
10 users (show)

See Also:
Fixed In Version: SI18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:06:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (217.93 KB, text/x-log)
2012-08-15 07:53 EDT, Meni Yakove
no flags Details
vdsm.log (614.58 KB, application/zip)
2012-08-15 07:54 EDT, Meni Yakove
no flags Details

  None (edit)
Description Meni Yakove 2012-08-15 07:53:47 EDT
Created attachment 604581 [details]
engine.log

Description of problem:
UI allow to create network with names such as eth0, eth1 etc..
When creating network with name eth0 and in SetupNetworks attache it to interface eth1 it will create BOND interface.

Version-Release number of selected component (if applicable):
rhevm-3.1.0-11.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.Create network with name eth0 and attach it to cluster.
2.Open SetupNetworks and attach the network eth0 to any interface

  
Actual results:
BOND creation window pop-up and let you create BOND interface. BOND failed to create

Expected results:
eth0 is bridge network for the selected interface.

Additional info:

MainProcess|Thread-13385::ERROR::2012-08-15 14:39:14,669::configNetwork::1261::setupNetworks::(setupNetworks) [Errno 2] No such file or directory: '/sys/class/net/eth3/brif'
Traceback (most recent call last):
  File "/usr/share/vdsm/configNetwork.py", line 1177, in setupNetworks
    _netinfo = netinfo.NetInfo()
  File "/usr/lib64/python2.6/site-packages/vdsm/netinfo.py", line 340, in __init__
    _netinfo = get()
  File "/usr/lib64/python2.6/site-packages/vdsm/netinfo.py", line 251, in get
    d['networks'][netname] = { 'ports': ports(devname),
  File "/usr/lib64/python2.6/site-packages/vdsm/netinfo.py", line 91, in ports
    return os.listdir('/sys/class/net/' + bridge + '/brif')
OSError: [Errno 2] No such file or directory: '/sys/class/net/eth3/brif'
MainProcess|Thread-13385::ERROR::2012-08-15 14:39:14,669::supervdsmServer::61::SuperVdsm.ServerCallback::(wrapper) Error in setupNetworks
Traceback (most recent call last):
  File "/usr/share/vdsm/supervdsmServer.py", line 59, in wrapper
    return func(*args, **kwargs)
  File "/usr/share/vdsm/supervdsmServer.py", line 107, in setupNetworks
    return configNetwork.setupNetworks(networks, bondings, **options)
  File "/usr/share/vdsm/configNetwork.py", line 1177, in setupNetworks
    _netinfo = netinfo.NetInfo()
  File "/usr/lib64/python2.6/site-packages/vdsm/netinfo.py", line 340, in __init__
    _netinfo = get()
  File "/usr/lib64/python2.6/site-packages/vdsm/netinfo.py", line 251, in get
    d['networks'][netname] = { 'ports': ports(devname),
  File "/usr/lib64/python2.6/site-packages/vdsm/netinfo.py", line 91, in ports
    return os.listdir('/sys/class/net/' + bridge + '/brif')
OSError: [Errno 2] No such file or directory: '/sys/class/net/eth3/brif'
Thread-13385::ERROR::2012-08-15 14:39:14,670::BindingXMLRPC::879::vds::(wrapper) unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 869, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/BindingXMLRPC.py", line 346, in setupNetworks
    return api.setupNetworks(networks, bondings, options)
  File "/usr/share/vdsm/API.py", line 1115, in setupNetworks
    supervdsm.getProxy().setupNetworks(networks, bondings, options)
  File "/usr/share/vdsm/supervdsm.py", line 59, in __call__
    return callMethod()
  File "/usr/share/vdsm/supervdsm.py", line 57, in <lambda>
    callMethod = lambda : getattr(self._supervdsmProxy._svdsm, self._funcName)(*args, **kwargs)
  File "<string>", line 2, in setupNetworks
  File "/usr/lib64/python2.6/multiprocessing/managers.py", line 740, in _callmethod
    raise convert_to_error(kind, result)
OSError: [Errno 2] No such file or directory: '/sys/class/net/eth3/brif'
Comment 1 Meni Yakove 2012-08-15 07:54:53 EDT
Created attachment 604584 [details]
vdsm.log
Comment 2 Martin Pavlik 2012-09-04 04:07:24 EDT
Problem reproduces on  Red Hat Enterprise Virtualization Manager Version: '3.1.0-14.el6ev' as well.

For me scenario with eth0 did not work since I have interfaces: em1, em2, p1p1, p1p2. Whenever I create network with same name as one of the physical interface, bug reproduces.
Comment 3 Alona Kaplan 2012-09-05 11:02:08 EDT
upstream commit 86a5d6079adcc62ea0f1337a3c2e6280b2beb9e5
Comment 5 Meni Yakove 2012-09-16 04:09:47 EDT
Verified on rhevm-3.1.0-16.el6ev.noarch.

I can drag network named "eth0" on eth0 interface (BOND not created).
Comment 6 Meni Yakove 2012-09-16 04:10:33 EDT
Verified on rhevm-3.1.0-16.el6ev.noarch.

I can drag network named "eth0" on eth0 interface (BOND not created).

Note You need to log in before you can comment on or make changes to this bug.