Bug 848364 - arecord fails with 2 audio adapters installed.
arecord fails with 2 audio adapters installed.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: alsa-lib (Show other bugs)
5.9
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jaroslav Kysela
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 07:53 EDT by Arthur Benoit
Modified: 2014-12-15 10:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:21:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from alsa-info.sh script (65.14 KB, text/plain)
2012-08-15 07:53 EDT, Arthur Benoit
no flags Details

  None (edit)
Description Arthur Benoit 2012-08-15 07:53:53 EDT
Created attachment 604583 [details]
Output  from alsa-info.sh script

Description of problem:
I ran alsamixer -c1 then selected  f4 and turned capture up and down from 80% to 100%.

I then attempted to test the alsa play and record features on the following adapters in the same workstation:
Audigy 4 [SB0610] and SBLive! Value [CT4832] adapters.

Play and record worked on the Audigy 4 but recording through the microphone failed on the SBLive!. After removing the second adapter which was the Audigy 4 from the server the record feature worked in my workstation. 

The following command was used for this test: 
arecord -f dat -d 10 -D hw:1,0 foo1.wav

aplay foo1.wav

Version-Release number of selected component (if applicable):

RHEL 5.9 - 2.6.18-333

How reproducible:

Very

Steps to Reproduce:
1. Attach Mic and headphones
2. Run arecord -f dat -d 10 -D hw:1,0 foo1.wav - speak into the microphone
3. Run aplay foo1.wav  - listen with headphones
  
Actual results:
Unable to hear audio output

Expected results:
Audio output should be captured

Additional info:
I have attached the output from alsa-info.sh script taken off the alsa debug page:
http://www.alsa-project.org/main/index.php/Help_To_Debug_Intel_HDA
Comment 1 Jaroslav Kysela 2014-01-29 04:36:31 EST
Please, attach "not working" alsa-info.sh and "working" alsa-info.sh to compare the mixer settings...
Comment 2 RHEL Product and Program Management 2014-03-07 08:46:51 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-02 09:21:18 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 4 Arthur Benoit 2014-12-15 10:20:51 EST
This is not critical.
Comment 5 Arthur Benoit 2014-12-15 10:23:05 EST
This is not critical.

Note You need to log in before you can comment on or make changes to this bug.