Bug 848367 - [rhevm-webadmin][UI] wrong icon when attach Direct Disk is failing in “Event” tab
[rhevm-webadmin][UI] wrong icon when attach Direct Disk is failing in “Event”...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity low
: ---
: 3.2.0
Assigned To: Asaf Shakarchi
vvyazmin@redhat.com
storage
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-08-15 08:20 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 14:06 EST (History)
9 users (show)

See Also:
Fixed In Version: sf3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## screen-shots (269.23 KB, image/png)
2012-08-15 08:20 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2012-08-15 08:20:24 EDT
Created attachment 604591 [details]
## screen-shots

Description of problem: wrong icon when attache Direct Disk is failing in “Event” tab

Version-Release number of selected component (if applicable):
Verified on RHEVM 3.1 - SI13.3 

RHEVM: rhevm-3.1.0-11.el6ev.noarch 
VDSM: vdsm-4.9.6-27.0.el6_3.x86_64 
LIBVIRT: libvirt-0.9.10-21.el6.x86_64 
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.298.el6_3.x86_64 
SANLOCK: sanlock-2.3-3.el6_3.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run scenario, when you failed attached Direct Disk (see screen shot) 
  
Actual results:
In Event tab (in Web-Admin UI), get en error “Failed to attache Disk dLUN-VirtIO to VM VM-01 (User: admin@internal), with “V” icon

Expected results:
Get “X” Icon, if operation attached Direct Disk failed.

Additional info:
Comment 1 Asaf Shakarchi 2012-11-18 10:01:26 EST
I can see why but I cannot reproduce this to verify that my patch works,

Please provide an exact details how to reproduce the direct disk attach failure,


Thanks.
Comment 2 Dafna Ron 2012-11-19 08:03:11 EST
steps:

you need two iscsi storage servers. one is for the direct lun and one for the master domain

1. in iscsi domain, create a vm with one disk and run it
2. create a direct lun from a lun located on the second storage server
3. block connectivity to the direct lun server from the host using iptables: 
iptables -A OUTPUT -d <server>  -j DROP
4. try to attach the direct lun to the running vm
Comment 3 Asaf Shakarchi 2012-11-26 07:04:31 EST
Patch submitted: http://gerrit.ovirt.org/#/c/9464/
Comment 4 vvyazmin@redhat.com 2013-01-08 10:04:41 EST
No issues are found

Verified on RHEVM 3.2 - SF03 environment 

RHEVM: rhevm-3.2.0-4.el6ev.noarch
VDSM: vdsm-4.10.2-3.0.el6ev.x86_64
LIBVIRT: libvirt-0.10.2-13.el6.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.348.el6.x86_64
SANLOCK: sanlock-2.6-2.el6.x86_64
Comment 5 Itamar Heim 2013-06-11 04:57:15 EDT
3.2 has been released
Comment 6 Itamar Heim 2013-06-11 04:57:16 EDT
3.2 has been released
Comment 7 Itamar Heim 2013-06-11 04:57:29 EDT
3.2 has been released
Comment 8 Itamar Heim 2013-06-11 04:59:36 EDT
3.2 has been released
Comment 9 Itamar Heim 2013-06-11 05:29:04 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.