Bug 848399 - Create a hudson job that builds on jdk7
Create a hudson job that builds on jdk7
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Build System (Show other bugs)
4.4
Unspecified Unspecified
high Severity high (vote)
: ---
: JON 3.1.1
Assigned To: Stefan Negrea
Mike Foley
:
Depends On: 850744 852094
Blocks: 682878 852815
  Show dependency treegraph
 
Reported: 2012-08-15 09:35 EDT by Heiko W. Rupp
Modified: 2012-08-31 14:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 852815 (view as bug list)
Environment:
Last Closed: 2012-08-31 14:35:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2012-08-15 09:35:42 EDT
We should have a hudson job that builds the release branch (and later master) on jdk7
Comment 1 Heiko W. Rupp 2012-08-16 17:02:29 EDT
Job has been created,but currently fails due to missing jar(s) in JBoss Nexus
Comment 2 Heiko W. Rupp 2012-08-20 10:55:01 EDT
annotations-jar is now present. Build now fails to create the webservices

iterate-wsprovide:
     [echo] *** Providing WebservicesManagerRemote wsdl...
[wsprovide] Error: Could not generate. (use --show-traces to see full traces)
[wsprovide] java.lang.IllegalStateException: Cannot build JAXB context
[wsprovide] 	at org.jboss.ws.metadata.builder.jaxws.JAXWSMetaDataBuilder.createJAXBContext(JAXWSMetaDataBuilder.java:984)
[wsprovide] 	at org.jboss.ws.metadata.builder.jaxws.JAXWSWebServiceMetaDataBuilder.buildWebServiceMetaData(JAXWSWebServiceMetaDataBuilder.java:154)
[wsprovide] 	at org.jboss.ws.tools.jaxws.impl.JBossWSProviderImpl.provide(JBossWSProviderImpl.java:108)
[wsprovide] 	at org.jboss.ws.tools.jaxws.impl.JBossWSProviderImpl.provide(JBossWSProviderImpl.java:124)
[wsprovide] 	at org.jboss.wsf.spi.tools.cmd.WSProvide.generate(WSProvide.java:183)
[wsprovide] 	at org.jboss.wsf.spi.tools.cmd.WSProvide.main(WSProvide.java:76)
[wsprovide] Caused by: org.jboss.ws.WSException: Failed to create JAXBContext
[wsprovide] 	at org.jboss.ws.core.jaxws.CustomizableJAXBContextFactory.createContext(CustomizableJAXBContextFactory.java:114)
[wsprovide] 	at org.jboss.ws.metadata.builder.jaxws.JAXWSMetaDataBuilder.createJAXBContext(JAXWSMetaDataBuilder.java:980)
[wsprovide] 	... 5 more
[wsprovide] Caused by: com.sun.xml.bind.v2.runtime.IllegalAnnotationsException: 1 counts of IllegalAnnotationExceptions
[wsprovide] java.lang.StackTraceElement does not have a no-arg default constructor.
[wsprovide] 	this problem is related to the following location:
[wsprovide] 		at java.lang.StackTraceElement
[wsprovide] 		at public java.lang.StackTraceElement[] java.lang.Throwable.getStackTrace()
[wsprovide] 		at java.lang.Throwable
[wsprovide] 		at private java.lang.Throwable[] org.rhq.enterprise.server.webservices.jaxws.ExceptionBean.suppressed
[wsprovide] 		at org.rhq.enterprise.server.webservices.jaxws.ExceptionBean
[wsprovide] 
[wsprovide] 	at com.sun.xml.bind.v2.runtime.IllegalAnnotationsException$Builder.check(IllegalAnnotationsException.java:102)
[wsprovide] 	at com.sun.xml.bind.v2.runtime.JAXBContextImpl.getTypeInfoSet(JAXBContextImpl.java:438)
[wsprovide] 	at com.sun.xml.bind.v2.runtime.JAXBContextImpl.<init>(JAXBContextImpl.java:286)
[wsprovide] 	at com.sun.xml.bind.v2.ContextFactory.createContext(ContextFactory.java:139)
[wsprovide] 	at com.sun.xml.bind.api.JAXBRIContext.newInstance(JAXBRIContext.java:105)
[wsprovide] 	at org.jboss.ws.core.jaxws.CustomizableJAXBContextFactory.createContext(CustomizableJAXBContextFactory.java:108)
[wsprovide] 	... 6 more
Comment 4 Heiko W. Rupp 2012-08-21 12:37:51 EDT
Webservices build failure seems to come from some more strict type checking in some jaxb/jaxws tools.

Other failures are FailoverList related, which are fixed in master already

And then there is a failure in the ScriptBindngTest with this cause:

Caused by: sun.org.mozilla.javascript.internal.EvaluatorException: The choice of Java constructor assertEquals matching JavaScript argument types (object,object) is ambiguous; candidate constructors are: 
    void assertEquals(java.util.Collection,java.util.Collection)
    void assertEquals(java.lang.Object[],java.lang.Object[]) (<Unknown source>#1)
Comment 6 Mike Foley 2012-08-31 14:35:31 EDT
java7 removed as a feature from jon 3.1.1.  java7 is not a requirement, ergo there can be no bug.

Note You need to log in before you can comment on or make changes to this bug.