Bug 848409 - Error while checking server version: No such file or directory
Error while checking server version: No such file or directory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-08-15 10:02 EDT by John Sefler
Modified: 2013-01-10 04:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:59:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-08-15 10:02:55 EDT
Description of problem:
see below

Version-Release number of selected component (if applicable):
see below

How reproducible:


Steps to Reproduce:
[root@jsefler-59server ~]# subscription-manager unregister
This system is currently not registered.
[root@jsefler-59server ~]# subscription-manager clean
All local data removed
[root@jsefler-59server ~]# subscription-manager version
Error while checking server version: No such file or directory
remote entitlement server: Unknown
remote entitlement server type: Unknown
subscription-manager: 1.0.13-1.git.27.2a76fe7.el5
python-rhsm: 1.0.5-1.git.1.1ce0910.el5

  
Actual results:
see above

Expected results:
DID NOT EXPECT:
Error while checking server version: No such file or directory


Additional info:
[root@jsefler-59server ~]# tail -f /var/log/rhsm/rhsm.log
2012-08-15 09:58:06,787 [DEBUG]  @profile.py:95 - Loading current RPM profile.
2012-08-15 09:58:07,011 [DEBUG]  @managercli.py:250 - Client Versions: {'subscription manager': '1.0.13-1.git.27.2a76fe7.el5', 'python-rhsm': '1.0.5-1.git.1.1ce0910.el5'} 
2012-08-15 09:58:07,012 [INFO]  @connection.py:498 - Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
2012-08-15 09:58:07,012 [INFO]  @connection.py:511 - Connection Built: host: jsefler-f14-candlepin.usersys.redhat.com, port: 8443, handler: /candlepin
2012-08-15 09:58:07,013 [DEBUG]  @managercli.py:257 - Server Versions: Not registered, unable to check server version
2012-08-15 09:58:07,014 [DEBUG]  @connection.py:323 - Loading CA PEM certificates from: /etc/rhsm/ca/
2012-08-15 09:58:07,014 [DEBUG]  @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2012-08-15 09:58:07,014 [DEBUG]  @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/jsefler-f14-candlepin.pem'
2012-08-15 09:58:07,015 [DEBUG]  @connection.py:305 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2012-08-15 09:58:07,016 [ERROR]  @utils.py:316 - No such file or directory
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/utils.py", line 305, in get_server_versions
    if cp.supports_resource("status"):
  File "/usr/lib64/python2.4/site-packages/rhsm/connection.py", line 538, in supports_resource
    self._load_supported_resources()
  File "/usr/lib64/python2.4/site-packages/rhsm/connection.py", line 525, in _load_supported_resources
    resources_list = self.conn.request_get("/")
  File "/usr/lib64/python2.4/site-packages/rhsm/connection.py", line 400, in request_get
    return self._request("GET", method)
  File "/usr/lib64/python2.4/site-packages/rhsm/connection.py", line 326, in _request
    context.load_cert(self.cert_file, keyfile=self.key_file)
  File "/usr/lib64/python2.4/site-packages/M2Crypto/SSL/Context.py", line 74, in load_cert
    m2.ssl_ctx_use_cert(self.ctx, certfile)
SSLError: No such file or directory
Comment 1 John Sefler 2012-08-15 10:05:09 EDT
Note that error goes away after registering...

[root@jsefler-59server ~]# subscription-manager register --username testuser1 --org admin
Password: 
The system has been registered with id: d502f498-e3ef-4960-84a2-e43ce07e9627 
[root@jsefler-59server ~]# subscription-manager version
remote entitlement server: 0.7.6-1
remote entitlement server type: subscription management service
subscription-manager: 1.0.13-1.git.27.2a76fe7.el5
python-rhsm: 1.0.5-1.git.1.1ce0910.el5
Comment 2 RHEL Product and Program Management 2012-08-15 10:17:39 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Bryan Kearney 2012-08-16 16:24:14 EDT
fixed in master at 6266cfc553941ad3668d4bdd26e94362e7536740
Comment 4 Shwetha Kallesh 2012-08-17 07:22:42 EDT
Marking verified!!

[root@dhcp201-115 ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5
subscription-manager-gui-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-migration-1.0.13-1.git.45.5cb55c8.el5


[root@dhcp201-115 ~]# subscription-manager unregister
System has been un-registered.
[root@dhcp201-115 ~]# subscription-manager clean
All local data removed
[root@dhcp201-115 ~]# subscription-manager version
registered to: Unknown
server type: Unknown
subscription-manager: 1.0.13-1.git.45.5cb55c8.el5
python-rhsm: 1.0.5-1.git.1.1ce0910.el5
Comment 6 errata-xmlrpc 2013-01-07 22:59:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.